第十五周oj刷题——Problem D: C++习题 对象数组输入与输出

Description
建立一个对象数组,内放n(n<10)个学生的数据(学号、成绩),用指针指向数组首元素,输出第奇数(1,3,5,7)个学生的数据。

Input
n和n个学生的学号、成绩

Output
奇数学生的数据

Sample Input
5
101 78.5
102 85.5
103 98.5
104 100.0
105 95.5
Sample Output
101 78.50
103 98.50
105 95.50


/* All rights reserved.
 * 文件名称:test.cpp
 * 作者:陈丹妮
 * 完成日期:2015年 6 月 21 日
 * 版 本 号:v1.0
 */
#include <iostream>
#include <iomanip>
using namespace std;
class Student
{
private:
    int n;
    double s;
public:
    void input();
    void display();
};
void Student::input()
{
    cin>>n>>s;
}
void Student::display()
{
    cout<<n<<" "<<s<<endl;
}
int main()
{
    const int NUM=10;
    Student stud[NUM];
    int n,i;
    cin>>n;
    for(i=0; i<n; i++)
        stud[i].input();
    cout<<setiosflags(ios::fixed);
    cout<<setprecision(2);
    Student *p=stud;
    for(i=0; i<n; p+=2,i+=2)
        p->display();
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值