hdu-1312 Red and Black DFS解法

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17185    Accepted Submission(s): 10436


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
一般的dfs做法即可。代码如下:
//
//  main.cpp
//  hdu1312
//
//  Created by Morris on 16/7/22.
//  Copyright © 2016年 Morris. All rights reserved.
//

#include <cstdio> 
#include <cstring> 

#define MAX_SZ 30

namespace {
    using std::scanf;
    using std::printf;
    using std::memset;
}

int w, h;
int cnt;
int dir[4][2] = { { 0, -1 }, { 0, 1 }, { -1, 0 }, { 1, 0 } };
char map[MAX_SZ][MAX_SZ];
int visit[MAX_SZ][MAX_SZ];

void dfs(int x, int y);

int main(int argc, const char *argv[])
{
    while (scanf("%d%d%*c", &w, &h)) {
        if (h == 0 && w == 0) {
            break;
        }
        
        int i, j, sx = 0, sy = 0;
        for (i = 0; i < h; ++i) {
            for (j = 0; j < w; ++j) {
                scanf("%c", &map[i][j]);
                if (map[i][j] == '@') {
                    sx = i;
                    sy = j;
                }
            }
            getchar();
        }
        
        cnt = 0;
        memset(visit, 0, sizeof(visit));
        dfs(sx, sy);
        
        printf("%d\n", cnt);
    }
    return 0;
}

void dfs(int x, int y)
{
    ++cnt;
    map[x][y] = '#';
    
    int i, tx, ty;
    for (i = 0; i < 4; ++i) {
        tx = x + dir[i][0];
        ty = y + dir[i][1];
        
        if (tx >= 0 && ty >= 0 && tx < h && ty < w && map[tx][ty] == '.') {
            dfs(tx, ty);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值