Parallelogram Counting(POJ 1971)

Parallelogram Counting
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 6258 Accepted: 2155

Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case. 
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000. 

Output

Output should contain t lines. 
Line i contains an integer showing the number of the parallelograms as described above for test case i. 

Sample Input

2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8

Sample Output

5
6
 
要知道两条相交直线 如果其交点为两条直线公共中点(两条直线中点相同),那么就能组成一个平行四边形:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std; 
struct node{
	int x,y;
}dian[1010],mid[1010*1010];

int cmp(node a,node b)
{
	if(a.x!=b.x)
		return a.x<b.x;
	else
		return a.y<b.y;
}
int main()
{
	int t,n,cont=0;
	scanf("%d",&t);
	while(t--)
	{	
		scanf("%d",&n);
		for(int i=1;i<=n;i++){
			scanf("%d%d",&dian[i].x,&dian[i].y);
		}
		int o=0;
		for(int i=1;i<=n;i++)
		{
			for(int j=i+1;j<=n;j++)
			{
				mid[o].x=dian[i].x+dian[j].x;//两点连线的中点横坐标(为了简便没除以2) 
				mid[o].y=dian[i].y+dian[j].y;
				o++;
			}
		}
		sort(mid,mid+o,cmp); //记得排序。。。 
		int next=0,ans=0;
		int sum=1;//一条边就有一个中点,所以sum最少为1; 
		for(int i=1;i<o;i++)
		{
			if(mid[i].x==mid[next].x&&mid[i].y==mid[next].y){//两条边中点相同,sum就加一; 
				sum++;
			}
			else{
				next=i;
				ans=ans+sum*(sum-1)/2;	//根据找到的有相同中点的边的条数(有相同中点那么一定相交)计算能组成多少个平行四边形,自己举几个例子就能看出来为啥这样; 
				sum=1;	// 遇到中点不同说明又有“一簇”拥有相同中点的相交的边,需要另外开始算; 
			}
		}
		printf("%d\n",ans);//输出平行四边形个数 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值