Factorial of large numbers bjfu1005 java实现大数阶乘

描述

Factorial, as we all know, is the product of all the positive integers from one up to and including a given integer. For example, factorial zero is assigned the value of one; factorial four is 1 × 2 × 3 × 4. Symbol: N! The N is the given integer. But it is hard to calculate the factorial when the N is large. Ben wrote a program to calculate N!(N<10000) when he was in grade one. So try it!

输入

The input consists of multiple test cases. One N (0<=N<=10000,integer) in a line for each test case. Process to the end of file.

输出

For each test case, print the value of N! in a single line.

样例输入

5
10
20
100

样例输出

120
3628800
2432902008176640000
93326215443944152681699238856266700490715968264381621468592963895217599993229915608941463976156518286253697920827223758251185210916864000000000000000000000000

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
	public static void main(String args[]){
		Scanner cin=new Scanner(System.in);
		int i;
		while (cin.hasNext()){
			i=cin.nextInt();
			getBigFactorial(i);
		}
		cin.close();
	}
	public static void getBigFactorial(int n) {
		if (n==0) 
			System.out.println("0");
		BigInteger result=new BigInteger("1");
		for (;n>0;n--) 
			result=result.multiply(new BigInteger(n+""));
		System.out.println(result);
	}
}

我的症结还在于,不会熟练的在int和Biginteger之间转换。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值