[POJ][1013]Counterfeit Dollar

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light.

这道题目乍一看觉得很简单,其实不然

我的第一个思路:

排除法,"ABCDEFGHIJKL"字符串,删掉even两边出现过的字符,和非even情况下两边没有出现的字符,剩下的就是假币

实际上这种方法得不到正确结果

比如下面这组数据

ABCDEF GHIJKL up 
ABHLEF GDIJKC down 
CD HA even

第二个思路:

设置一个int[12]的数组,对应12个字母,表示怀疑程度,出现在even两边的字母怀疑程度减一,出现一次就减一次,出现在up和down两边的加一,出现一次就加一次

实际上这个也得不到结果,因为有些正确的字母也混在up和down情况里面,会导致多个字母怀疑程度同时最大

比如上面那组数据,这种思路就无解

第三个思路:

网上看来的,是第二个思路的改进,设置一个bool[12]用于保存银币是否为真,初始化都为假,再设置int[12]表示怀疑程度

even两边的字母的bool数组对应的值赋true

注意up和down的处理,怀疑程度现在是两个方向,怀疑它是重的假币,或者怀疑它是轻的假币

每次出现up或者down,就让轻的一方的所有银币怀疑值减一,让重的一方怀疑值加一,最后比较的时候除去已经确认为真的银币,会发现所有不确定是否真假的银币里面,只有一个的怀疑值不为0,其他的都为0.那个不为0的银币就是假币,如果怀疑值大于0,那么假币重,否则假币轻

下面是AC代码

#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
    int n=0;
    cin>>n;
    string left,right,result;
    while (n--) {
        int suspect[12]={0};
        bool isTrue[12]={0};
        for(int i=0;i<3;i++) {
            cin>>left>>right>>result;
            if (result=="even") {
                for (int i=0; i<left.size(); i++) {
                    isTrue[left[i]-65] = true;
                    isTrue[right[i]-65] = true;
                }
            } else {
                if (result=="up") {
                    for (int i=0; i<left.size(); i++) {
                        suspect[left[i]-65]++;
                        suspect[right[i]-65]--;
                    }
                } else {
                    for (int i=0; i<left.size(); i++) {
                        suspect[left[i]-65]--;
                        suspect[right[i]-65]++;
                    }
                }
            }
        }
        int index=0,temp=0;
        for (int i=0; i<12; i++) {
            if (!isTrue[i] && abs(suspect[i])>temp) {
                temp = abs(suspect[i]);
                index = i;
            }
        }
        char t = index+65;
        cout<<t<<" is the counterfeit coin and it is "<<(suspect[index]>0?"heavy":"light")<<"."<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值