maven工程相关lib包

转载 2018年04月17日 12:59:38
<dependencies>
<dependency>
<groupId>antlr</groupId>
<artifactId>antlr</artifactId>
<version>2.7.6</version>
</dependency>
<dependency>
<groupId>aopalliance</groupId>
<artifactId>aopalliance</artifactId>
<version>1.0</version>
</dependency>
<dependency>
<groupId>asm</groupId>
<artifactId>asm</artifactId>
<version>3.2</version>
</dependency>
<dependency>
<groupId>org.aspectj</groupId>
<artifactId>aspectjrt</artifactId>
<version>1.6.2</version>
</dependency>
<dependency>
<groupId>org.aspectj</groupId>
<artifactId>aspectjweaver</artifactId>
<version>1.6.2</version>
</dependency>


<dependency>
<groupId>com.mchange</groupId>
<artifactId>c3p0</artifactId>
<version>0.9.5.2</version>
</dependency>
<dependency>
<groupId>cglib</groupId>
<artifactId>cglib-nodep</artifactId>
<version>2.2</version>
</dependency>
<dependency>
<groupId>commons-beanutils</groupId>
<artifactId>commons-beanutils</artifactId>
<version>1.8.3</version>
</dependency>
<dependency>
<groupId>commons-codec</groupId>
<artifactId>commons-codec</artifactId>
<version>1.4</version>
</dependency>
<dependency>
<groupId>commons-collections</groupId>
<artifactId>commons-collections</artifactId>
<version>3.2</version>
</dependency>
<dependency>
<groupId>commons-dbcp</groupId>
<artifactId>commons-dbcp</artifactId>
<version>1.4</version>
</dependency>
<dependency>
<groupId>commons-fileupload</groupId>
<artifactId>commons-fileupload</artifactId>
<version>1.2.1</version>
</dependency>
<dependency>
<groupId>commons-io</groupId>
<artifactId>commons-io</artifactId>
<version>2.4</version>
</dependency>
<dependency>
<groupId>org.apache.commons</groupId>
<artifactId>commons-lang3</artifactId>
<version>3.4</version>
</dependency>
<dependency>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
<version>1.1.1</version>
</dependency>
<dependency>
<groupId>commons-pool</groupId>
<artifactId>commons-pool</artifactId>
<version>1.6</version>
</dependency>
<dependency>
<groupId>commons-validator</groupId>
<artifactId>commons-validator</artifactId>
<version>1.6</version>
</dependency>
<dependency>
<groupId>dom4j</groupId>
<artifactId>dom4j</artifactId>
<version>1.6.1</version>
<exclusions>
<exclusion>
<groupId>xml-apis</groupId>
<artifactId>xml-apis</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>net.sf.ezmorph</groupId>
<artifactId>ezmorph</artifactId>
<version>1.0.6</version>
</dependency>
<dependency>
<groupId>org.freemarker</groupId>
<artifactId>freemarker</artifactId>
<version>2.3.15</version>
</dependency>
<dependency>
<groupId>org.apache.httpcomponents</groupId>
<artifactId>httpclient</artifactId>
<version>4.3.1</version>
</dependency>
<dependency>
<groupId>org.apache.httpcomponents</groupId>
<artifactId>httpcore</artifactId>
<version>4.3.1</version>
</dependency>
<dependency>
<groupId>javassist</groupId>
<artifactId>javassist</artifactId>
<version>3.9.0.GA</version>
</dependency>
<dependency>
<groupId>javax.mail</groupId>
<artifactId>mail</artifactId>
<version>1.4</version>
</dependency>
<dependency>
<groupId>com.jcraft</groupId>
<artifactId>jsch</artifactId>
<version>0.1.44-1</version>
</dependency>
<dependency>
<groupId>javax.transaction</groupId>
<artifactId>jta</artifactId>
<version>1.1</version>
</dependency>


<dependency>
<groupId>log4j</groupId>
<artifactId>log4j</artifactId>
<version>1.2.14</version>
</dependency>
<dependency>
<groupId>mysql</groupId>
<artifactId>mysql-connector-java</artifactId>
<version>5.1.35</version>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-api</artifactId>
<version>1.7.5</version>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-log4j12</artifactId>
<version>1.7.5</version>
</dependency>


<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-core</artifactId>
<version>${spring.version}</version>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-test</artifactId>
<version>${spring.version}</version>
</dependency>
<dependency>
<groupId>jstl</groupId>
<artifactId>jstl</artifactId>
<version>1.1.2</version>
</dependency>


<dependency>
<groupId>org.apache.ws.commons.util</groupId>
<artifactId>ws-commons-util</artifactId>
<version>1.0.2</version>
<exclusions>
<exclusion>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
</exclusion>
<exclusion>
<groupId>xml-apis</groupId>
<artifactId>xml-apis</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.apache.xmlrpc</groupId>
<artifactId>xmlrpc-client</artifactId>
<version>3.1</version>
</dependency>
<dependency>
<groupId>org.apache.xmlrpc</groupId>
<artifactId>xmlrpc-common</artifactId>
<version>3.1</version>
</dependency>
<dependency>
<groupId>net.sf.json-lib</groupId>
<artifactId>json-lib</artifactId>
<version>2.2.3</version>
<classifier>jdk15</classifier>
</dependency>
<dependency>
<groupId>com.alibaba</groupId>
<artifactId>fastjson</artifactId>
<version>1.2.16</version>
</dependency>
<!-- jackson -->
<dependency>
<groupId>com.fasterxml.jackson.core</groupId>
<artifactId>jackson-databind</artifactId>
<version>${jackson.version}</version>
</dependency>
<dependency>
<groupId>com.fasterxml.jackson.module</groupId>
<artifactId>jackson-module-jaxb-annotations</artifactId>
<version>${jackson.version}</version>
</dependency>
<dependency>
<groupId>com.fasterxml.jackson.datatype</groupId>
<artifactId>jackson-datatype-joda</artifactId>
<version>${jackson.version}</version>
</dependency>
<dependency>
<groupId>org.codehaus.jackson</groupId>
<artifactId>jackson-mapper-asl</artifactId>
<version>1.9.13</version>
</dependency>
<!-- <dependency> <groupId>org.springframework</groupId> <artifactId>spring</artifactId> 
<version>${spring.version}</version> </dependency> -->
<!-- <dependency> <groupId>org.springframework</groupId> <artifactId>spring-core</artifactId> 
<version>${spring.version}</version> </dependency> -->
<!-- <dependency> <groupId>com.danga</groupId> <artifactId>memcached</artifactId> 
<version>2.5.1</version> </dependency> -->




<dependency>
<groupId>ch.ethz.ganymed</groupId>
<artifactId>ganymed-ssh2</artifactId>
<version>261</version>
</dependency>


<dependency>
<groupId>org.springframework.data</groupId>
<artifactId>spring-data-commons</artifactId>
<version>1.5.1.RELEASE</version>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-context</artifactId>
<version>${spring.version}</version>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-beans</artifactId>
<version>${spring.version}</version>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-orm</artifactId>
<version>${spring.version}</version>
</dependency>


<!-- <dependency> <groupId>org.springframework</groupId> <artifactId>spring-test</artifactId> 
<version>${spring.version}</version> <scope>test</scope> </dependency> -->


<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-web</artifactId>
<version>${spring.version}</version>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-jms</artifactId>
<version>${spring.version}</version>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-webmvc</artifactId>
<version>${spring.version}</version>
</dependency>


<dependency>
<groupId>javax.servlet</groupId>
<artifactId>servlet-api</artifactId>
<version>2.5</version>
</dependency>


<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-context-support</artifactId>
<version>3.1.0.RELEASE</version>
</dependency>
<dependency>
<groupId>org.quartz-scheduler</groupId>
<artifactId>quartz</artifactId>
<version>1.8.6</version>
</dependency>
<dependency>
<groupId>javax.servlet</groupId>
<artifactId>jstl</artifactId>
<version>1.2</version>
</dependency>


<!-- Mybatis 开发包 -->
<!-- <dependency> <groupId>org.mybatis</groupId> <artifactId>mybatis-spring</artifactId> 
<version>1.3.0</version> </dependency> -->


<!-- Mybatis 和Spring的 整合包,是mybatis出的 -->
<!-- <dependency> <groupId>org.mybatis</groupId> <artifactId>mybatis</artifactId> 
<version>3.4.1</version> </dependency> -->


<!-- hibernate -->
<dependency>
<groupId>org.hibernate</groupId>
<artifactId>hibernate-core</artifactId>
<version>${hibernate.version}</version>
</dependency>
<dependency>
<groupId>org.hibernate</groupId>
<artifactId>hibernate-ehcache</artifactId>
<version>${hibernate.version}</version>
</dependency>
<!-- 二级缓存ehcache -->
<dependency>
<groupId>net.sf.ehcache</groupId>
<artifactId>ehcache</artifactId>
<version>2.9.0</version>
</dependency>


<!-- <dependency> <groupId>org.apache.httpcomponents</groupId> <artifactId>httpclient</artifactId> 
<version>4.3.1</version> </dependency> <dependency> <groupId>org.apache.httpcomponents</groupId> 
<artifactId>httpcore</artifactId> <version>4.3.1</version> </dependency> -->


<dependency>
<groupId>org.codehaus.jackson</groupId>
<artifactId>jackson-mapper-asl</artifactId>
<version>1.9.13</version>
</dependency>


<dependency>
<groupId>org.apache.zookeeper</groupId>
<artifactId>zookeeper</artifactId>
<version>3.4.6</version>
</dependency>


<dependency>
<groupId>com.github.sgroschupf</groupId>
<artifactId>zkclient</artifactId>
<version>0.1</version>
<exclusions>
<exclusion>
<groupId>org.apache.zookeeper</groupId>
<artifactId>zookeeper</artifactId>
</exclusion>
<exclusion>
<groupId>jline</groupId>
<artifactId>jline</artifactId>
</exclusion>
</exclusions>
</dependency>


<!-- <dependency> <groupId>org.apache.activemq</groupId> <artifactId>activemq-core</artifactId> 
<version>${activemq-core-version}</version> </dependency> <dependency> <groupId>org.apache.activemq</groupId> 
<artifactId>activemq-pool</artifactId> <version>${activemq-version}</version> 
<exclusions> <exclusion> <groupId>org.apache.geronimo.specs</groupId> <artifactId>geronimo-jms_1.1_spec</artifactId> 
</exclusion> </exclusions> </dependency> -->


<dependency>
<groupId>org.jsoup</groupId>
<artifactId>jsoup</artifactId>
<version>1.7.3</version>
</dependency>


<dependency>
<groupId>com.google.code.simple-spring-memcached</groupId>
<artifactId>simple-spring-memcached</artifactId>
<version>3.2.1</version>
</dependency>


<dependency>
<groupId>com.google.code.simple-spring-memcached</groupId>
<artifactId>xmemcached-provider</artifactId>
<version>3.2.1</version>
</dependency>


<!-- activiti -->
<!-- <dependency> <groupId>org.activiti</groupId> <artifactId>activiti-bpmn-converter</artifactId> 
<version>${activiti.version}</version> </dependency> <dependency> <groupId>org.activiti</groupId> 
<artifactId>activiti-bpmn-layout</artifactId> <version>${activiti.version}</version> 
</dependency> <dependency> <groupId>org.activiti</groupId> <artifactId>activiti-bpmn-model</artifactId> 
<version>${activiti.version}</version> </dependency> <dependency> <groupId>org.activiti</groupId> 
<artifactId>activiti-common-rest</artifactId> <version>${activiti.version}</version> 
</dependency> <dependency> <groupId>org.activiti</groupId> <artifactId>activiti-engine</artifactId> 
<version>${activiti.version}</version> </dependency> <dependency> <groupId>org.activiti</groupId> 
<artifactId>activiti-image-generator</artifactId> <version>${activiti.version}</version> 
</dependency> <dependency> <groupId>org.activiti</groupId> <artifactId>activiti-json-converter</artifactId> 
<version>${activiti.version}</version> </dependency> <dependency> <groupId>org.activiti</groupId> 
<artifactId>activiti-process-validation</artifactId> <version>${activiti.version}</version> 
</dependency> <dependency> <groupId>org.activiti</groupId> <artifactId>activiti-rest</artifactId> 
<version>${activiti.version}</version> </dependency> <dependency> <groupId>org.activiti</groupId> 
<artifactId>activiti-simple-workflow</artifactId> <version>${activiti.version}</version> 
</dependency> <dependency> <groupId>org.activiti</groupId> <artifactId>activiti-spring</artifactId> 
<version>${activiti.version}</version> </dependency> <dependency> <groupId>org.codehaus.groovy</groupId> 
<artifactId>groovy-all</artifactId> <version>2.4.7</version> </dependency> -->


<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>4.11</version>
</dependency>


<dependency>
<groupId>com.google.code.gson</groupId>
<artifactId>gson</artifactId>
<version>2.2.4</version>
</dependency>


<dependency>
<groupId>commons-httpclient</groupId>
<artifactId>commons-httpclient</artifactId>
<version>3.1</version>
</dependency>


<dependency>
<groupId>jdom</groupId>
<artifactId>jdom</artifactId>
<version>1.0</version>
</dependency>
<dependency>
<groupId>org.bouncycastle</groupId>
<artifactId>bcprov-jdk16</artifactId>
<version>1.45</version>
</dependency>
<!-- <dependency> <groupId>com.unionpay.acp.sdk</groupId> <artifactId>upacp_sdk</artifactId> 
<version>1.0.0</version> </dependency> -->
<dependency>
<groupId>com.qiniu</groupId>
<artifactId>qiniu-java-sdk</artifactId>
<version>7.2.7</version>
</dependency>
<!-- druid connection pool -->
<dependency>
<groupId>com.alibaba</groupId>
<artifactId>druid</artifactId>
<version>${druid.version}</version>
</dependency>
<!-- shiro -->
<dependency>
<groupId>org.apache.shiro</groupId>
<artifactId>shiro-core</artifactId>
<version>${shiro.version}</version>
</dependency>
<dependency>
<groupId>org.apache.shiro</groupId>
<artifactId>shiro-web</artifactId>
<version>${shiro.version}</version>
</dependency>
<dependency>
<groupId>org.apache.shiro</groupId>
<artifactId>shiro-spring</artifactId>
<version>${shiro.version}</version>
</dependency>
<dependency>
<groupId>org.apache.shiro</groupId>
<artifactId>shiro-ehcache</artifactId>
<version>${shiro.version}</version>
</dependency>
<dependency>
<groupId>org.apache.shiro</groupId>
<artifactId>shiro-quartz</artifactId>
<version>${shiro.version}</version>
</dependency>
<dependency>
<groupId>axis</groupId>
<artifactId>axis-jaxrpc</artifactId>
<version>1.4</version>
</dependency>
<dependency>
<groupId>axis</groupId>
<artifactId>axis</artifactId>
<version>1.4</version>
</dependency>


<dependency>
<groupId>org.kohsuke.jinterop</groupId>
<artifactId>j-interop</artifactId>
<version>2.0.5</version>
</dependency>


<dependency>
<groupId>com.hynnet</groupId>
<artifactId>sqljdbc4-chs</artifactId>
<version>4.0.2206.100</version>
</dependency>




<dependency>
<groupId>xom</groupId>
<artifactId>xom</artifactId>
<version>1.2.5</version>
</dependency>


<dependency>
<groupId>jmimemagic</groupId>
<artifactId>jmimemagic</artifactId>
<version>0.1.2</version>
</dependency>


<dependency>
<groupId>org.apache.tomcat</groupId>
<artifactId>tomcat7-websocket</artifactId>
<version>7.0.73</version>
</dependency>


<dependency>
<groupId>org.glassfish.websocket</groupId>
<artifactId>websocket-api</artifactId>
<version>0.2</version>
</dependency>


<dependency>
<groupId>kocel</groupId>  <!--自定义 -->
<artifactId>kocel_mes_1.7</artifactId>    <!--自定义 -->
<version>1.0</version> <!--自定义 -->
<scope>system</scope> <!--system,类似provided,需要显式提供依赖的jar以后,Maven就不会在Repository中查找它 -->
<systemPath>${local.lib.path}/kocel_mes_1.7.jar</systemPath> <!--项目根目录下的lib文件夹下 -->
</dependency>


<dependency>
<groupId>kocel</groupId>
<artifactId>kocel_report</artifactId>
<version>1.0</version>
<scope>system</scope>
<systemPath>${local.lib.path}/kocel_report.jar</systemPath>
</dependency>


<dependency>
<groupId>kocel</groupId>
<artifactId>org.openscada.opc.dcom_1.1.0.v20130529</artifactId>
<version>1.0</version>
<scope>system</scope>
<systemPath>${local.lib.path}/org.openscada.opc.dcom_1.1.0.v20130529.jar</systemPath>
</dependency>
<dependency>
<groupId>kocel</groupId>
<artifactId>org.openscada.opc.lib_1.1.0.v20130529</artifactId>
<version>1.0</version>
<scope>system</scope>
<systemPath>${local.lib.path}/org.openscada.opc.lib_1.1.0.v20130529.jar</systemPath>
</dependency>


<dependency>
<groupId>kocel</groupId>
<artifactId>kocel_km_plan</artifactId>
<version>1.0</version>
<scope>system</scope>
<systemPath>${local.lib.path}/kocel_km_plan.jar</systemPath>
</dependency>


<dependency>
<groupId>commons-net</groupId>
<artifactId>commons-net</artifactId>
<version>3.5</version>
</dependency>
</dependencies>

Maven项目同时使用lib下的Jar包

测试于:Maven 3.0.5, eclipse-jee-indigo-SR2-win32 配置步骤: 在WEB-INF下新建lib目录并加入自己的包; 右键项目 -> Buil...
  • white__cat
  • white__cat
  • 2016-04-23 16:00:05
  • 9113

maven编译,使用WEB-INFO/lib下的Jar包

修改pom.xm 增加 org.apache.maven.plugins maven-compiler-plugin 3.1 1.7
  • qiu265843468
  • qiu265843468
  • 2017-12-25 12:42:17
  • 102

maven构建项目时,下载的jar放在项目的lib目录中

我们在使用Maven构建项目的时候,pom.xml下载下来的jar包是在本地仓库中,往往有些同学是需要或者习惯于在项目的lib目录下找jar包,那么我们只需要在pom.xml中最后加上以下代码:   ...
  • ruben95001
  • ruben95001
  • 2017-02-22 16:21:35
  • 2501

MAVEN引入第三方JAR包

maven 第三方 JAR 适用环境:自己没有搭建MAVEN仓库服务器,或者 将JAR包传入到服务器,无法下载的情况 在POM.XML中加入 com.gxhs.analysis...
  • lilt085163
  • lilt085163
  • 2017-03-31 10:07:28
  • 779

maven 项目引入lib目录中的jar包

compile ${basedir}/src ${basedir}/WebRoot/WEB-INF/classes ${basedir}/src **/*.java maven-war...
  • jiangxuchen
  • jiangxuchen
  • 2015-12-21 18:47:54
  • 6656

maven lib文件夹引用 但是项目报错的解决办法

把maven 本地repository里 报错的包 所在小文件夹 整个删除,然后让maven重新download下来,就好了。用命令行还是eclipse里的maven update到影响不大。 貌...
  • xb12369
  • xb12369
  • 2017-07-19 11:12:56
  • 593

解决Maven Web工程,用Eclipse导出War时,没有Lib的问题

解决Maven Web工程,用Eclipse导出War时,没有Lib的问题右键项目属性–>Deployment Assebly然后看你有没有添加了maven Dependencies 发布,如果没有的...
  • s445320
  • s445320
  • 2016-08-18 17:20:52
  • 2986

关于既使用maven编译,又使用lib下的Jar包的问题

1 maven和make、ant项目编译工具的区别    参考:http://blog.csdn.net/j50435578/article/details/9698071 2 关于既使用maven编...
  • bjydlcq
  • bjydlcq
  • 2016-08-12 16:02:27
  • 796

eclipse自动部署web项目时WEB-INF\lib目录下缺少maven依赖jar包

右键点击工程,属性(properties),选择deployment assembly选项,单击add按钮,如下图: 650) this.width=650;" title="29e383c4-f71...
  • jethai
  • jethai
  • 2016-08-28 14:02:55
  • 1340

maven管理Java web项目WEB-INF/lib中jar包不能被引入的问题解决

maven管理Java web项目WEB-INF/lib中jar包不能被引入的问题解决
  • tszxlzc
  • tszxlzc
  • 2016-02-23 20:57:16
  • 5483
收藏助手
不良信息举报
您举报文章:maven工程相关lib包
举报原因:
原因补充:

(最多只允许输入30个字)