1020. Tree Traversals (25)

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:

4 1 6 3 5 7 2


#include<iostream>
#include<queue>
using namespace std;

int root,l,r,ll,rr;
int node[1002][2];
int a[10002], b[1002];
int n;

void dfs1(int &x, int l, int r, int ll, int rr)
{
	if (l > r) x = 0;
	for (int i = l; i <= r; i++)
	{
		if (a[i] == b[rr])
		{
			x=i;
			dfs1(node[x][0], l, i - 1, ll, ll+i-l-1);
			dfs1(node[x][1], i + 1, r, ll +i-l, rr - 1);
		}
	}
}

void dfs(int&x, int l, int r, int ll, int rr)  
{  
    if (l > r) x = 0;  
    for (int i = l; i <= r; i++)  
    {  
        if (a[i] == b[rr])  
        {  
            x = i;  
            dfs(node[x][0], l, i - 1, ll, ll + i - l - 1);  
            dfs(node[x][1], i + 1, r, ll + i - l, rr - 1);  
        }  
    }  
}  

int main()
{
	
	cin >> n;
	
	for (int i = 1; i <= n; i++)
	{
		cin >> b[i];
	}
	for (int i = 1; i <= n; i++) cin >> a[i];
	dfs1(root, 1, n, 1, n);
	queue<int> p;
	p.push(root);
	 while (!p.empty())  
    {  
        int q = p.front();  p.pop();  
        if (root != q) printf(" ");  
        printf("%d", a[q]);  
        if (node[q][0]) p.push(node[q][0]);  
        if (node[q][1]) p.push(node[q][1]);  
    }  
	return 0;

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值