POJ 2559 Largest Rectangle in a Histogram --维护单调栈

相当于对于当前点 i ,求向左和向右分别能延伸到的位置 l[i], r[i],然后最后求 MAX(h[i] * (r[i]-l[i]) ).意思是向两边找到比它矮的位置为止.至于为什么比他矮就不能延伸了,这是因为要计算的高度是 h[i],如果遇到比 h[i] 小的还继续延伸,那么另一端也可以继续延伸,动态规划就不成立了.

求 l[i] 时,维护一个递增栈,考虑当前的 i,如果栈顶元素不小于 i ,弹出,直到栈顶元素小于 i ,l[i] = s.top(),并将 i 压入栈中.

可类似方法从右向左求 r[i].

Tips : 另外,这题有矩形是 1*0 的,所以得让 h[0] = h[n+1] = -1,并压栈,充当两个端点.不然就会 Runtime Error咯.


总时间限制: 1000ms 内存限制: 65536kB
描述
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
输入
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
输出
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

样例输入
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
样例输出
8
4000
#include <iostream>
#include <stdio.h>
#include <stack>

using namespace std;

long long n, mmax, h[101000], l[101000], r[101000];
stack<long> s;

int main()
{
    while(scanf("%lld",&n) && n!= 0)
    {
        mmax = 0;
        h[0] = -1; h[n+1] = -1;
        while(! s.empty())
        {
            s.pop();//清空栈
        }

        for(long i=1;i<=n;i++)
        {
            scanf("%lld",&h[i]);
        }
        //求 l[i]
        s.push(0);//将h[0]压栈
        for(long i=1;i<=n;i++)
        {
            while(h[s.top()] >= h[i])
            {
                s.pop();
            }
            l[i] = s.top();
            s.push(i);
        }
        //求 r[i]
        while(! s.empty())
        {
            s.pop();
        }
        s.push(n+1);
        for(long i=n;i>=1;i--)
        {
            while(h[s.top()] >= h[i])
            {
                s.pop();
            }
            r[i] = s.top();
            s.push(i);
        }
        for(long i=1;i<=n;i++)
        {
            long temp = h[i] * (r[i]-l[i]-1);
            if( temp > mmax )
            {
                mmax = temp;
            }
        }
        printf("%lld\n",mmax);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值