解决/usr/lib64/libstdc++.so.6和/lib64/libc.so.6版本过低问题

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/poxiaonie/article/details/74059023

在CentOS7.0中编译好MySQL5.7.14之后,然后在CentOS6.5中初始化MySQL,执行:

/usr/local/mysql/bin/mysqld --version

出现如下问题:

./bin/mysqld: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./bin/mysqld)        
./bin/mysqld: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./bin/mysqld)

初步分析,出现这种问题就是因为编译库的编译器和编译当前程序的编译器版本是不一样的,在具体一点就是因为,当前程序的编译器的版本是比较低的,只要升级一下就可以了。

/usr/lib64/libstdc++.so.6升级

可以用如下命令查看一下当前GCC版本:

[root@haughty mysql] strings /usr/lib/libstdc++.so.6 | grep GLIBCXX  

GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH

并没有动态库中要求的GCC版本 “GLIBCXX_3.4.15”,所以需要进行升级一下我们的GCC版本
过程如下:

[root@haughty software] wget http://ftp.de.debian.org/debian/pool/main/g/gcc-4.7/libstdc++6_4.7.2-5_amd64.deb   #下载较新版本的GCC libstdc库
[root@haughty software] ar -x libstdc++6_4.7.2-5_amd64.deb  #解压
[root@haughty software] tar -zxvf data.tar.gz   #解压
[root@haughty software] cp usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.17 /usr/lib64  #拷贝至/usr/lib64下
[root@haughty software] rm -rf /usr/lib64/libstdc++.so.6    #删除低版本库的软连接
[root@haughty software] ln -s /usr/lib64/libstdc++.so.6.0.17 /usr/lib64/libstdc++.so.6

到现在升级就完成了。我们在去执行以下下面的命令

[root@haughty software] strings /usr/lib/libstdc++.so.6 | grep GLIBCXX 
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_3.4.15
GLIBCXX_3.4.16
GLIBCXX_3.4.17
GLIBCXX_DEBUG_MESSAGE_LENGTH

libstdc++.so.6库升级完毕。。。

/lib64/libc.so.6升级

升级之前:

[root@haughty mysql]#strings /lib64/libc.so.6 |grep GLIBC
GLIBC_2.2.5
GLIBC_2.2.6
GLIBC_2.3
GLIBC_2.3.2
GLIBC_2.3.3
GLIBC_2.3.4
GLIBC_2.4
GLIBC_2.5
GLIBC_2.6
GLIBC_2.7
GLIBC_2.8
GLIBC_2.9
GLIBC_2.10
GLIBC_2.11
GLIBC_2.12
GLIBC_PRIVATE
[root@haughty software]# wget http://ftp.gnu.org/gnu/glibc/glibc-2.14.tar.gz
[root@haughty software]# tar -zxvf  glibc-2.14.tar.gz
[root@haughty software]# cd glibc-2.14
[root@haughty glibc-2.14]# ./configure --prefix=/usr/glibc-2.14

这一步可能会报如下error:

configure: error: you must configure in a separate build directory

此时,只需要cd到上级目录进行configure即可。

[root@haughty glibc-2.14]# cd ../
[root@haughty software]# ./glibc-2.14/configure --prefix=/usr/glibc-2.14
[root@haughty software]# make
[root@haughty software]# make install
[root@haughty software]# cp /usr/glibc-2.14/lib/libc.so.6 /lib64/
[root@haughty mysql]# strings /lib64/libc.so.6 |grep GLIBC
GLIBC_2.2.5
GLIBC_2.2.6
GLIBC_2.3
GLIBC_2.3.2
GLIBC_2.3.3
GLIBC_2.3.4
GLIBC_2.4
GLIBC_2.5
GLIBC_2.6
GLIBC_2.7
GLIBC_2.8
GLIBC_2.9
GLIBC_2.10
GLIBC_2.11
GLIBC_2.12
GLIBC_2.13
GLIBC_2.14
GLIBC_PRIVATE

/lib64/libc.so.6升级完毕。。。。

展开阅读全文

没有更多推荐了,返回首页