无法识别的配置节connectionStrings

无法识别的配置节connectionStrings

asp.net1.1升级到2.0的方法

问题:
配置错误 
说明: 在处理向该请求提供服务所需的配置文件时出错。请检查下面的特定错误详细信息并适当地修改配置文件。分析器错误信息: 无法识别的配置节“connectionStrings”源错误:行 1: <configuration>行 2: 行 3: <connectionStrings/>行 4:    ......

源文件: F:\User\site\CS_2.1.60809.935_SDK\source\Web\web.config    行: 3
原因:用vs2005开发的asp.net应用程序需要使用.net framework 2.0,而在iis中的默认.net环境是1.1。这时将发生不可识别的节点的问题。解决办法:将.net环境升级为2.0,开始-》运行-》cmd-》C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i 完了之后打开IIS,右键点击站点-->属性-->ASP.NET标签中的版本改成2.0.50727就可以了。

你可以通过这个链接引用该篇文章:http://jclhy.bokee.com/viewdiary.16155874.html



操作系统:win2003
IIS:6.0

目的:将ASP.NET 1.1升级为ASP.NET 2.0
准备工作:下载.NET Framework 2.0

方案一:先安装.NET Framework 2.0,再安装IIS6.0

方案二:如果先安装iis6再安装.NET Framework 2.0则需要到visul studio tools的命令提示符中输入aspnet_regiis -i注冊2.0,成功后再在iis中的“web服务扩展”中将ASP.NET2.0设为允许。
具体方法:
运行cmd,在命令行输入“C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i”即可。

打开IIS,点开任意一个站点属性,可发现多了个选项卡——“ASP.NET”,其中显示版本为2.0则升级成功。


  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 扫一扫,分享海报

参与评论 您还未登录,请先 登录 后发表或查看评论
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值