1137. Final Grading (25)

 

For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G = (Gmid-termx 40% + Gfinalx 60%) if Gmid-term > Gfinal, or Gfinal will be taken as the final grade G. Here Gmid-term and Gfinal are the student's scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores Gp's; the second one contains M mid-term scores Gmid-term's; and the last one contains N final exam scores Gfinal's. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID Gp Gmid-term Gfinal G

If some score does not exist, output "-1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qualified student.

Sample Input:
6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81
Sample Output:
missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

提交代

 

/*
考试的时候用map,字符串和整形数映射,最后一个点万年超时,刚刚试一下用字符串和结构体映射,一遍就过
心中一万只草你马在奔腾
有成绩的第一个条件就是编程分在两百及两百以上,没有满足这个条件的后面的分数可以不用考虑,直接忽略
所有的初始化都在输出编程成绩时完成,期中期末置-1,总成绩置0,后面再根据输入的成绩进行修改 
编程分满足条件判断G是否大于等于60,满足就放入准备好了的vector中
最后排序输出就可以。 
*/ 
#include<iostream>
#include<algorithm>
#include<string>
#include<map>
#include<vector>
using namespace std;
struct node{
	string name;
	int g1,g2,gb,g;
	node(string nm="",int p=-1,int m=-1,int f=-1,int a=0):name(nm),gb(p),g1(m),g2(f),g(a){}
	//重载,成绩相同按学号排序 
	bool operator < (const node &a)const{
		return a.g == g ? a.name > name : a.g < g;
	}
};

int main(){
	int p,m,n;
	string str;
//	freopen("input.txt","r",stdin);
	map<string,node>mp;
	vector<node>v,result;
	int score;
	scanf("%d%d%d",&p,&m,&n);
	for(int i = 0;i < p;i++){
		cin>>str>>score;
		if(score >= 200)
			mp[str]=node(str,score,-1,-1,0);
	}
	
	for(int i = 0;i <  m;i++){
		cin>>str>>score;
		if(mp.count(str)){
			mp[str].g1 = score;
		}else{
			continue;
		}
	}
	
	for(int i = 0;i <  n;i++){
		cin>>str>>score;
		if(mp.count(str)){
			mp[str].g2 = score;
			if(mp[str].g1>mp[str].g2){
				mp[str].g=(mp[str].g1*0.4+mp[str].g2*0.6+0.5);
			}else{
				mp[str].g = score;
			}
			if(mp[str].g >= 60){
				v.push_back(mp[str]);
			}
		}else{
			continue;
		}
	}
	sort(v.begin(),v.end());
	for(int i = 0;i < v.size();i++){
		cout<<v[i].name;
		printf(" %d %d %d %d\n",v[i].gb,v[i].g1,v[i].g2,v[i].g);
	}
	return 0;
} 

 

 

 

 

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值