J - Perfect Pth Powers解题报告


J - Perfect Pth Powers
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

We say that x is a perfect square if, for some integer b, x = b 2. Similarly, x is a perfect cube if, for some integer b, x = b 3. More generally, x is a perfect pth power if, for some integer b, x = b p. Given an integer x you are to determine the largest p such that x is a perfect p th power.

Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the largest integer p such that x is a perfect p th power.

Sample Input

17
1073741824
25
0

Sample Output

1
30
2

我发现写解题报告还是很有好处的,所以从今天起好好的写解题报告。
这个题目的大意就是给出一个数a,找到一个数的p次幂等于这个数,要求是p是最大的。
我首先将输入的数a开根号,因为除了1,p的最小的数就是2了(负数就另当别论了),然后取t=2~sqrt(a),求t的p次幂,因为t是从小到大,如果有p满足就一定是最大的,所以找到了p就马上退出,输出。
负数的话,还是先开根号,不过要注意的是负数的p一定是奇数哈,完了,有错误请纠正。
代码如下:

#include<stdio.h>
#include<math.h>
#include<iostream>
using namespace std;
int main()
{
	long double a,i,j,p,sum,num;
	while(cin>>a&&a!=0)
	{
		 sum=1,num=1;
		 if(a>0)
		 {
			 for(i=2;i<=sqrt(a)+1;i++)//去根号a,缩小范围
			{
				for(j=2;;j++)
			{
				for(p=0;p<j;p++)//求i的j次幂
				{
					sum=sum*i;
				}
				if(sum==a)//判断是否满足
					{
						num=j;
						goto end;//满足的话就退出
					}
					if(sum>a)
					{
						goto top;
					}
				sum=1;
			}
top:			sum=1;
		 }
		 }
		 else
		 {
			  sum=1,num=1;
			 a=-a;
			  for(i=2;i<=sqrt(a)+1;i++)
			{
				for(j=3;;j+=2)//负数和正数不一样,只能为奇数
			{
				for(p=0;p<j;p++)
				{
					sum=sum*i;
				}
				if(sum==a)
					{
						num=j;
						goto end;
					}
					if(sum>a)
					{
						goto top1;//不满足的话继续进行
					}
				sum=1;
			}
top1:			sum=1;
			}
		 }
		end:;
	cout<<num<<endl;
	}

		return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值