1004. Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output

0 1

对广度优先搜索的变通,目前还是很难自己想到思路;

/*广度优先搜索**/
#include <iostream>
#include <vector>
#include <queue>
#include <iterator>
#include <utility>
#define MAX 105
using namespace std;

vector< vector<int> > node(105);

vector<int> bfs()
{
    int counter = 0, level = 0;
    pair<int, int> temp;
    vector<int> ans;
    queue< pair<int, int> > myque;
    vector<int>::iterator it;
    myque.push(make_pair(1,level));//根节点为0层
    while(!myque.empty())
    {
        temp = myque.front();
        myque.pop();
        if(level < temp.second)//遇到层数增加则更新
        {
            ans.push_back(counter);//该层总叶子数
            level = temp.second;
            counter = 0;//计数清零
        }
        if(node[temp.first].empty())//如果为空则证明没有儿子,为叶子计数
        {
            counter++;
            continue;
        }
        for(it=node[temp.first].begin(); it!=node[temp.first].end(); it++)
        {
            myque.push(make_pair(*it, level+1));//对每层结点的儿子依次入队并且记录层数
        }
    }
    ans.push_back(counter);
    return ans;
}
int main()
{
    int n, m, temp, id, k;
    vector<int> ans;
    while(cin >> n >> m)
    {
        for(int i=0; i<m; i++)
        {
            cin >> id >> k;
            for(int j=0; j<k; j++)
            {
                cin >> temp;
                node[id].push_back(temp);
            }
        }
    }
    ans = bfs();
    for(vector<int>::size_type i=0; i<ans.size(); i++)
    {
        if(i != ans.size()-1)
            cout << ans[i] << " ";
        else
            cout << ans[i] << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值