NAT端口映射,实现外网访问内网服务器

前言

本篇文章利用Cisco Packet Tracer网络模拟进行NAT端口映射,实现外网访问内网服务器。

一、搭建网络拓扑

在这里插入图片描述

网络拓扑图

1.1 配置server和pc

机器名IP地址网关IP子网掩码
Server0192.168.1.2192.168.1.1255.255.255.0
Server1192.168.1.3192.168.1.1255.255.255.0
PC0114.25.63.24114.25.63.1255.255.255.0

1.1.1 配置server0

在这里插入图片描述

1.1.2 配置server1

在这里插入图片描述

1.1.3 配置pc0

在这里插入图片描述

1.2 配置客户路由器

1.2.1 配置路由器IP

接口名称IP地址子网掩码
fa0/0192.168.1.1255.255.255.0
fa0/166.1.1.1255.255.255.0

配置信息如下:

1. 配置fa0/0接口
Router>enable
Router#
Router#configure
Router(config)#
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#

2. 配置fa0/1接口
Router(config)#interface fa0/1
Router(config-if)#ip address 66.1.1.1 255.255.255.0
Router(config-if)#no shutdown

1.2.2 配置静态路由

为客户路由器配置默认路由,让客户路由器可以达到114.25.63.0/24网络。

命令:ip route 目标网段 目标网段掩码 下一跳路由的IP
这里设置默认路由
下一跳路由IP的意思是通过其可以到达目标网段
Router(config)#ip route 0.0.0.0 0.0.0.0 66.1.1.254

或者可以设置静态路由
Router(config)#ip route 114.25.63.0 255.255.255.0 66.1.1.254

以上两种配置的其中一种,均可以到达114.25.63.0/24网络

1.3 配置ISP路由器

接口名称IP地址子网掩码
fa0/066.1.1.254255.255.255.0
fa0/1114.25.63.1255.255.255.0

配置信息如下:

1. 配置fa0/0接口
Router>enable
Router#
Router#configure
Router(config)#
Router(config)#interface fa0/0
Router(config-if)#ip address 66.1.1.254 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#

2. 配置fa0/1接口
Router(config)#interface fa0/1
Router(config-if)#ip address 114.25.63.1 255.255.255.0
Router(config-if)#no shutdown

以上配置完成后,测试各个主机的连通性,这里不再介绍。

二、配置端口映射

2.1 在客户路由器配置端口映射

由于这里使用HTTP服务,则应该对应两个服务器的80端口进行映射

端口映射表
私网IP私网机器端口公网IP公网机器端口
192.168.1.28066.1.1.26666
192.168.1.38066.1.1.28888

配置信息如下:

Router>enable
Router#
Router#configure
Router(config)#
1. 配置接口fa0/0为内网口
Router(config)#interface fa0/0
Router(config-if)#ip nat inside
Router(config-if)#exit
Router(config)#
2. 配置接口fa0/1为外网口
Router(config)#interface fa0/1
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#

3. 私网IP 端口->公网IP 端口
命令:ip nat inside source static 协议(udp或tcp) 私网ip 端口 公网ip 端口
Router(config)#ip nat inside source static tcp 192.168.1.2 80 66.1.1.2 6666
Router(config)#ip nat inside source static tcp 192.168.1.3 80 66.1.1.2 8888

2.2 测试公网计算机访问私网服务器

2.2.1 PC0向server0发送HTTP请求

如果映射成功,则可以通过66.1.1.2:6666访问server0(192.168.1.2)

在这里插入图片描述
这里,可以去修改server0的index.html的内容

在这里插入图片描述

2.2.1 PC0向server1发送HTTP请求

如果映射成功,则可以通过66.1.1.2:8888访问server1(192.168.1.3)

在这里插入图片描述

总结

nat还有一种静态配置,即一个公网IP映射一个私网IP。
nat端口映射可以实现一个公网IP映射多个私网IP,只需要控制端口号的选择。

  • 34
    点赞
  • 11
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值