D - Silver Cow Party

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10

题解:

两次Dijkstra算法。对于求从i到x的最短路我们可以把他看为求x到i的最短路,我们只需要把lowcost设置为cost[i][x]即可。最短路径只需要从x到i的最短路径代表他们返回的最短路径,然后将所有边反过来,再从x到i的最短路径代表他们来参加聚会的最短路径,这样对应相加找出一个最大值就可以了,当然其实不需要将所有边反过来,在dijkstra里面两次查询i到x最短路lowcost[i],和从x回到i的最短返回距离lowcostf[i].

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
typedef long long LL;
const int maxn = 1010;
const int INF = 0x3f3f3f3f;
int n,m,x;
int lowcost[maxn],lowcostf[maxn],cost[maxn][maxn];
bool vis[maxn];

void dijkstra()
{
   for(int i=1;i<=n;i++)
   {
       lowcost[i]=cost[i][x];
       lowcostf[i]=cost[x][i];
       vis[i]=false;
   }

   for(int i=1;i<=n;i++)
   {
       int MIN = INF;
       int k = -1;
       for(int j=1;j<=n;j++)
       {
           if(!vis[j]&&MIN>lowcost[j])
           {
               MIN = lowcost[j];
               k = j;
           }
       }
       if(k==-1) break;
       vis[k]=true;
       for(int j=1;j<=n;j++)
       {
           if(!vis[j]&&lowcost[k]+cost[j][k]<lowcost[j])
           {
                 lowcost[j]=lowcost[k]+cost[j][k];
           }
       }
   }

   memset(vis,false,sizeof(vis));

   for(int i=1;i<=n;i++)
   {
       int MIN = INF;
       int k = -1;
       for(int j=1;j<=n;j++)
       {
           if(!vis[j]&&MIN>lowcostf[j])
           {
               MIN = lowcostf[j];
               k = j;
           }
       }
       if(k==-1) break;
       vis[k]=true;
       for(int j=1;j<=n;j++)
       {
           if(!vis[j]&&lowcostf[k]+cost[k][j]<lowcostf[j])
           {
               lowcostf[j] = lowcostf[k]+cost[k][j];
           }
       }
   }
}

int main()
{
    while(cin>>n>>m>>x)
    {
        for(int i=0;i<=n;i++)
          for(int j=0;j<=n;j++)
          {
              cost[i][j]=(i==j)?0:INF;
          }
        int a,b,c;
        for(int i=0;i<m;i++)
        {
           cin>>a>>b>>c;
           cost[a][b]=c;
        }
        dijkstra();
        int ans = -1;
        for(int i=1;i<=n;i++)
        {
           ans = max(ans,lowcost[i]+lowcostf[i]);
        }
        cout<<ans<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值