O - Extended Traffic(SPFA判负环)

Dhaka city is getting crowded and noisy day by day. Certain roads always remain blocked in congestion. In order to convince people avoid shortest routes, and hence the crowded roads, to reach destination, the city authority has made a new plan. Each junction of the city is marked with a positive integer (≤ 20) denoting the busyness of the junction. Whenever someone goes from one junction (the source junction) to another (the destination junction), the city authority gets the amount (busyness of destination - busyness of source)3 (that means the cube of the difference) from the traveler. The authority has appointed you to find out the minimum total amount that can be earned when someone intelligent goes from a certain junction (the zero point) to several others.

Input
Input starts with an integer T (≤ 50), denoting the number of test cases.

Each case contains a blank line and an integer n (1 < n ≤ 200) denoting the number of junctions. The next line contains n integers denoting the busyness of the junctions from 1 to n respectively. The next line contains an integer m, the number of roads in the city. Each of the next m lines (one for each road) contains two junction-numbers (source, destination) that the corresponding road connects (all roads are unidirectional). The next line contains the integer q, the number of queries. The next q lines each contain a destination junction-number. There can be at most one direct road from a junction to another junction.

Output
For each case, print the case number in a single line. Then print q lines, one for each query, each containing the minimum total earning when one travels from junction 1 (the zero point) to the given junction. However, for the queries that gives total earning less than 3, or if the destination is not reachable from the zero point, then print a ‘?’.

Sample Input
2

5
6 7 8 9 10
6
1 2
2 3
3 4
1 5
5 4
4 5
2
4
5

2
10 10
1
1 2
1
2
Sample Output
Case 1:
3
4
Case 2:
?

题解:

题目是给出一个有向图,给出一定的边,可以求出边权。如果<3或者达不到输出问号。如果一点在负环中,那么这个点可以到达的所有点,都可以是无穷小,使用SPFA计算dist,同时找出负环的点,DFS这个点,标记所有这个点能到达的点。

代码:

#include <bits/stdc++.h>

using namespace std;

const int MAXN = 200;
const int INF = 0x3f3f3f3f;

struct Edge
{
    int v,cost;
    Edge(int _v=0,int _cost=0):v(_v),cost(_cost){}
};

vector<Edge> E[MAXN];

void addedge(int u,int v,int w)
{
    E[u].push_back(Edge(v,w));
}

bool vis[MAXN];
int cnt[MAXN];
int dist[MAXN];

bool cir[MAXN];

void dfs(int u)
{
    cir[u]=true;
    for(int i=0;i<E[u].size();i++)
    {
        if(!cir[E[u][i].v])
        {
            dfs(E[u][i].v);
        }
    }
}

void SPFA(int start,int n)
{
    memset(vis,false,sizeof(vis));
    for(int i=1;i<=n;i++) dist[i]=INF;
    vis[start]=true;
    dist[start]=0;
    queue<int> que;

    que.push(start);
    memset(cnt,0,sizeof(cnt));
    cnt[start]=1;
    memset(cir,false,sizeof(cir));
    while(!que.empty())
    {
        int u = que.front();
        que.pop();
        vis[u]=false;
        for(int i=0;i<E[u].size();i++)
        {
            int v = E[u][i].v;
            if(cir[v]) continue;
            if(dist[v]>dist[u]+E[u][i].cost)
            {
                dist[v]=dist[u]+E[u][i].cost;
                if(!vis[v])
                {
                    vis[v]=true;
                    que.push(v);
                    cnt[v]++;
                    if(cnt[v]>n) dfs(v);
                }
            }
        }
    }
}

int a[MAXN];



int main()
{
    int T;
    int iCase = 0;
    cin>>T;
    while(T--)
    {
        iCase++;
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++) cin>>a[i];
        int m;
        int u,v;
        for(int i=1;i<=n;i++) E[i].clear();
        cin>>m;
        while(m--)
        {
            cin>>u>>v;
            addedge(u,v,(a[v]-a[u])*(a[v]-a[u])*(a[v]-a[u]));
        }
        SPFA(1,n);
        printf("Case %d:\n",iCase);
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d",&u);
            if(cir[u] || dist[u] < 3 || dist[u] == INF)
                printf("?\n");
            else printf("%d\n",dist[u]);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值