CentOS7 安装sentry(最新)

Sentry 是一款基于 Django实现的错误日志收集和聚合的平台,它是 Python 实现的,但是其日志监控功能却不局限于python,对诸如 Node.jsphp,rubyC#,java 等语言的项目都可以做到无缝集成,甚至可以用来对iOSAndroid 移动客户端以及 Web前端异常进行跟踪。我们可以在程序中捕获异常,并发送到 Sentry服务端进行聚合统计、展示和报警。

   sentry官方推荐docker方式安装,使用到了docker-compose。docker至少是1.10.3以上的版本。为此需要使用centos7。

  Docker在2016年很早的时候就明确了将会在企业级方面重点跟进。而在短短的一年时间之内推出的1.12和1.13的版本在功能上确实是很大的进步。而在2017年的3月1号之后,Docker的版本命名开始发生变化,同时将CE版本和EE版本进行分开了,EE是企业版,CE是社区版,如果直接使用‘

yum install -y docker-engine 或者
yum install -y docker 安装的都是老版本docker

现在在网上看到的大部分教程都还是使用旧版本,本次我们采用的是安装Docker CE版:

1、线卸载旧版本Docker

1

yum remove docker  docker-common  docker-selinux  docker-engine

2、安装依赖包

1

yum install -y yum-utils   device-mapper-persistent-data   lvm2

3、添加docker yum源

yum-config-manager     --add-repo     https://download.docker.com/linux/centos/docker-ce.repo

4、可选操作:允许拓展最新的不稳定的repository

1

yum-config-manager --enable docker-ce-edge

5、安装Docker

yum -y install docker-ce

6、启动Docker

1

systemctl start docker

7、测试Docker

1

docker run hello-world

如果以上步骤成功则测试时会返回如下结果:

8、查看docker版本,docker至少是1.10.3以上的版本,如果我没有指定版本默认安装最新的则肯定满足条件

docker --version

返回

9、继续安装依赖,需要用到git,docker-compose,pip等组件

1

2

3

4

yum install epel-release

yum  install -y python-pip

pip  install docker-compose

yum install git

10、 浏览器打开https://github.com/getsentry/onpremise,在README.md文件里面有

我们先运行第一步创建所需的文件夹

mkdir -p data/{sentry,postgres}

然后我们ls会发现多了一个data文件夹,如下:

 

11、克隆该项目

git clone https://github.com/getsentry/onpremise.git

完成后会多一个

 

12、这一步很重要,官网并没有说明这一步,我们需要cd进入data目录

1

cd onpremise/

13、生成秘钥

docker-compose run --rm web config generate-secret-key

14、把刚才最后一行的秘钥复制下来

vim docker-compose.yml

 

 

 

15、创建数据库

docker-compose run --rm web upgrade

在创建数据的时候会提示我们是否需要创建管理员,我们选择Y,填入对应的邮箱地址和密码,等一下登陆WEB需要,是否是超级管理员也选择Y 

16、启动所有服务

docker-compose up -d

17、验证docker启动状态

docker ps

 

到此我们的sentry就已经部署完成了,访问我们的  服务器ip:9000端口就可以看见sentry的界面

展开阅读全文

没有更多推荐了,返回首页