uva1494 - Qin Shi Huang's National Road System

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China -- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty -- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor " in Chinese.

\epsfbox{p5713.eps}

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:

There were n cities in China and Qin Shi Huang wanted them all be connected by n - 1 roads, in order that he could go to every city from the capital city Xianyang. Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible -- So Qin Shi Huang decided that the value of A/B(the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.

Would you help Qin Shi Huang?

A city can be considered as a point, and a road can be considered as a line segment connecting two points.

Input 

The first line contains an integer t meaning that there are t test cases (t$ \le$10).

For each test case:

The first line is an integer n meaning that there are n cities (2 < n$ \le$1000).

Then n lines follow. Each line contains three integers XY and P (0$ \le$XY$ \le$1000, 0 < P < 100000)(XY) is the coordinate of a city andP is the population of that city.

It is guaranteed that each city has a distinct location.

Output 

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

Sample Input 

2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40

Sample Output 

65.00
70.00


比较水的mst,主要利用的是求次小生成树的办法,

需要求出任意两点之间的maxw[u][v]


#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>

using namespace std;

#define N 1010
const int inf=0x3f3f3f3f;

struct data
{
    int x,y,v;
};

struct Edge
{
    int u,v;
    double w;
};

int now[N],pre[N*N],son[N*N];
double val[N*N];
bool used[N*N];
double maxw[N][N];
int fa[N];
data a[N];
Edge e[N*N];
int n,m,tot,root;

double dist(data x,data y)
{
    return ( sqrt( 1.0* ( (x.x-y.x)*(x.x-y.x)+(x.y-y.y)*(x.y-y.y) ) ) );
}

bool cmp(Edge x, Edge y)
{
    return x.w<y.w;
}

int up(int x)
{
    return fa[x]==x? x : fa[x]=up(fa[x]);
}

void add(int u,int v,double w)
{
    tot++;
    pre[tot]=now[u];
    now[u]=tot;
    son[tot]=v;
    val[tot]=w;
}

void dfs(int u,int father)
{
    int p=now[u];
    while (p>0)
    {
        int v=son[p];
        if (v!=father)
        {
            maxw[root][v]=max ( maxw[root][u], val[p]);
            dfs(v,u);
        }
        p=pre[p];
    }
}



int main()
{
    int T;
    scanf("%d",&T);
    while (T--)
    {
        memset(used,0,sizeof(used));
        memset(now,0,sizeof(now));
        memset(maxw,0,sizeof(maxw));
        tot=0;
        scanf("%d",&n);
        for (int i=1; i<=n; i++)
            scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].v);
        int m=0;
        for (int i=1; i<=n; i++)
            for (int j=i+1; j<=n; j++)
            {
                m++;
                e[m].u=i;   e[m].v=j;
                e[m].w=dist( a[i], a[j] );
            }
        sort(e+1,e+m+1,cmp);
        for (int i=1; i<=n; i++)
            fa[i]=i;
        int cnt=0;
        double mst=0;
        for (int i=1; i<=m; i++)
        {
            int f1=up(e[i].u);
            int f2=up(e[i].v);
            if (f1!=f2)
            {
                cnt++;
                fa[f1]=f2;
                mst+=e[i].w;
                add(e[i].u,e[i].v,e[i].w);
                add(e[i].v,e[i].u,e[i].w);

                if (cnt==n-1) break;
            }
        }
        for (int i=1; i<=n; i++)
        {
            root=i;
            dfs( i, 0 );
        }
        double ans=0;
        for (int i=1; i<=n; i++)
            for (int j=i+1; j<=n; j++)
            {
                if ( 1.0*(a[i].v+a[j].v) / ( mst-maxw[i][j] ) > ans )
                    ans=1.0*(a[i].v+a[j].v) / ( mst-maxw[i][j] ) ;

            }
        printf("%.2lf\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值