HDU 1517 A Multiplication Game(博弈)

                                   A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5051    Accepted Submission(s): 2870


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

Input
Each line of input contains one integer number n.
 

Output
For each line of input output one line either

Stan wins.

or

Ollie wins.

assuming that both of them play perfectly.
 

Sample Input
  
  
162 17 34012226
 

Sample Output
  
  
Stan wins. Ollie wins. Stan wins.
题意:2 个人玩游戏,从 1 开始,轮流对数进行累乘,直到超过一个指定的值。所乘的数在2——9之间
如果输入是 2 ~ 9 ,因为Stan 是先手,所以Stan 必胜
如果输入是 10~18 ,Ollie 必胜
如果输入是 19 ~ 162,Stan 的必胜态
如果输入是 163 ~ 324 ,这是又是Ollie的必胜态
如果"我方"首先给出了一个在N不断除18后的得到不足18的
数M,"我方"就可以取得胜利,然而双方都很聪明,所以这样胜负就决定于N了,如果N不断除
18后的得到不足18的数M,如果1<M<=9则先手胜利,即Stan wins.如果9<M<=18
则后手胜利.
#include<stdio.h>
int main()
{
    double  n;
    while(scanf("%lf",&n)!=EOF)
    {
        while(n>18)n/=18;
        if(n<=9) printf("Stan wins.\n");
        else   printf("Ollie wins.\n");
    }    
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值