【解决】yum 安装 出错 Error: Protected multilib versions:

我安装zlib出错:

yum install zlib-1.2.3-29.el6.i686


Error: Protected multilib versions: zlib-1.2.3-29.el6.i686 != zlib-1.2.3-27.el6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


原因:多个库共存冲突


解决办法:在执行命令后面加上:--setopt=protected_multilib=false 


再次执行:yum install zlib-1.2.3-29.el6.i686  --setopt=protected_multilib=false 

ok!

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页