PKU-1724(DFS + 剪枝)




ROADS
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8684 Accepted: 3219

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find  the shortest path from the city 1 to the city N  that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

Source



写了一次也是没有写成功,我就发现自己DFS写的还是不够熟练,所以写法比较不成熟,所以很多题目自己写出来的都是四不像,而且也过不了题目;

这样很让人悲哀,自己有思路,但是是因为自己的代码量不够而做不出来题目,这样的话,真的是很让人伤心呀...


这个是DFS写的,但其实我是要写最短路 + 优先队列的..


#include <stdio.h>
#include <string.h>
#include <iostream>
#include <string>

using namespace std;

const int maxe = 10011;

const int maxn = 111;

const int INF = 0x3fffffff;

int K;	

int N;

int R;

struct Edge
{
	int v;
	int length;
	int val;
	int next;
}e[maxe];

int head[maxn];

int vis[maxn];

int min_len;

int idx;

void init()
{
	idx = 0;
	min_len = INF;
	memset(head, -1, sizeof(head));
	memset(vis, 0, sizeof(vis));
}

void addEdge(int a, int b, int length, int val)
{
	e[idx].v = b;
	e[idx].length = length;
	e[idx].val = val;
	e[idx].next = head[a];
	head[a] = idx++;
}

void DFS(int v, int now_len, int now_money)
{
	if (now_len >= min_len)
	{
		return ;
	}
	if (v == N && now_len < min_len)
	{
		min_len = now_len;
		return ;
	}
	int p = head[v];
	while (p != -1)
	{
		int point = e[p].v;
		int len = e[p].length;
		int money = e[p].val;
		if (!vis[point] && now_money + money <= K)
		{
			vis[point] = 1;
			DFS(point, now_len + len, now_money + money);
			vis[point] = 0;
		}
		p = e[p].next;
	}
	return ;
}
int main()
{
	while (scanf("%d", &K) != EOF)
	{
		init();
		scanf("%d", &N);
		scanf("%d", &R);
		int S, D, L, T;
		for (int i = 0; i < R; i++)
		{
			scanf("%d%d%d%d", &S, &D, &L, &T);
			addEdge(S, D, L, T);
//			addEdge(D, S, L, T);
		}
		DFS(1, 0, 0);
		printf("%d\n", min_len);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值