华为super vlan:相同子网属于不同VLAN实现通信

配置VLAN聚合示例

该组网的特点是以较少的IP地址实现了VLAN间通信。

组网需求

某公司拥有多个部门且位于同一网段,为了提升业务安全性,将不同部门的员工划分到不同VLAN中。现由于业务需要,不同部门间的员工需要互通。

图1所示,研发部和测试部分布在不同的VLAN中,现需要实现不同VLAN间的员工可以互相访问。

图1 配置VLAN聚合组网图 

华为super <wbr>vlan:相同子网属于不同VLAN实现通信。


配置思路

采用如下思路配置VLAN聚合:

1.  把Switch接口加入到相应的sub-VLAN中。

2.  把sub-VLAN聚合为super-VLAN。

3.  配置super-VLAN的IP地址。

4.  配置super-VLAN的Proxy ARP。

数据准备

为完成此配置例,需准备如下的数据:

·         GE0/0/1和GE0/0/2属于VLAN2

·         GE0/0/3和GE0/0/4属于VLAN3

·         super-VLAN的ID为4

·         super-VLAN的IP地址为100.1.1.12

操作步骤

1.       配置接口类型

配置接口GE0/0/1为Access类型。

system-view
[Quidway] interface gigabitethernet 0/0/1
[Quidway-GigabitEthernet0/0/1] port link-type access
[Quidway-GigabitEthernet0/0/1] quit

配置接口GE0/0/2为Access类型。

system-view
[Quidway] interface gigabitethernet 0/0/2
[Quidway-GigabitEthernet0/0/2] port link-type access
[Quidway-GigabitEthernet0/0/2] quit

配置接口GE0/0/3为Access类型。

system-view
[Quidway] interface gigabitethernet 0/0/3
[Quidway-GigabitEthernet0/0/3] port link-type access
[Quidway-GigabitEthernet0/0/3] quit

配置接口GE0/0/4为Access类型。

system-view
[Quidway] interface gigabitethernet 0/0/4
[Quidway-GigabitEthernet0/0/4] port link-type access
[Quidway-GigabitEthernet0/0/4] quit

2.       配置VLAN2

创建VLAN2。

[Quidway] vlan 2

向VLAN2中加入GE0/0/1和GE0/0/2。

[Quidway-vlan2] port gigabitethernet 0/0/1 0/0/2
[Quidway-vlan2] quit

3.       配置VLAN3

创建VLAN3。

[Quidway] vlan 3

向VLAN3中加入GE0/0/3和GE0/0/4。

[Quidway-vlan3] port gigabitethernet 0/0/3 0/0/4
[Quidway-vlan3] quit

4.       配置VLAN4

配置super-VLAN。

[Quidway] vlan 4
[Quidway-vlan4] aggregate-vlan
[Quidway-vlan4] access-vlan 2 to 3

配置VLANIF。

[Quidway] interface vlanif 4
[Quidway-Vlanif4] ip address 100.1.1.12 255.255.255.0
[Quidway-Vlanif4] quit

5.       配置PC

分别为各PC配置IP地址,并使它们和VLAN4处于同一网段。

配置成功后,各PC与Switch之间可以相互ping通,但VLAN2的PC与VLAN3的PC间不可以相互ping通。

6.       配置Proxy ARP

7.  [Quidway] interface vlanif 4
[Quidway-Vlanif4] arp-proxy inter-sub-vlan-proxy enable

8.       检查配置结果

配置完成后,VLAN2的PC与VLAN3的PC间可以相互ping通。

配置文件

Switch的配置文件

#
sysname Quidway
#
vlan batch 2 to 4
#
vlan 4
aggregate-vlan
access-vlan 2 to 3
#
interface Vlanif4
ip address 100.1.1.12 255.255.255.0
arp-proxy inter-sub-vlan-proxy enable
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 2
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 2
#
interface GigabitEthernet0/0/3
port link-type access
port default vlan 3
#
interface GigabitEthernet0/0/4
port link-type access
port default vlan 3
#
return
相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页