poj 3087 Shuffle'm Up (kuangbin带你飞--简单搜索)

Shuffle'm Up
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7739 Accepted: 3559

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1


题目大意:

就是给定三个字符串,s1,s2,ss;让你判断是否能够通过 s1 和 s2 交叉来达到 ss, 

ps:  s1 的第一张在第一张,然后依次交叉;


解题思路:


其实我不知道为什么bin神把这道题归为搜索,我用的是集合模拟也是能做的,

重点是去重;

上代码:

/**
2015 - 09 - 16 晚上
Author: ITAK


Motto:


今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
**/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <map>
#include <set>
using namespace std;
typedef long long LL;
const int maxn = 105;
const double eps = 1e-7;
bool vis[maxn][maxn];
const int dir[4][2]= {1, 0, 0, 1, -1, 0, 0, -1};
char map[maxn][maxn];


string s1, s2, ss, str;
int main()
{
    set<string> s;
    int T;
    scanf("%d",&T);
    for(int j=1; j<=T; j++)
    {
        int m;
        scanf("%d", &m);
        cin>>s1>>s2>>ss;
        int cnt = 0;
        s.clear();///清屏
        ///很关键,没有这句的话,str[ind++] = s2[i];这样的访问str是越界的
        str = ss;
        while (1)
        {
            int ind = 0;
            for (int i=0; i<m; i++)
            {
                str[ind++] = s2[i];
                str[ind++] = s1[i];
            }
            cnt++;
            if(str == ss)
            {
                printf("%d %d\n", j, cnt);
                break;
            }
            if(s.count(str) == 1)
            {
                printf("%d -1\n", j);
                break;
            }
            else
            {
                /**
                string str1, str2 = "War and Peace";
                str1.assign( str2, 4, 3 );
                //str2 字符串的第4个字符位置开始赋值给str1,长度为3个字符
                cout << str1 << endl;  ;
                **/
                s.insert(str);
                s1.assign(str, 0, m);//str从0位开始的m个字符
                s2.assign(str, m, m);
            }
        }
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值