hdu 1051 Wooden Sticks(贪心)

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15215    Accepted Submission(s): 6242


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 
题目大意:
有T组数据,首先给定一个数m,接下来有2*m个数,每两个数表示木头的长和重量,现在有这样一种机器,
每次通过一个木头,如果后面的每个值都 > 前面的数,则不需要调整时间,否则时间 +1
解题思路:

这是一个比较简单的贪心问题,首先我们进行对木头的 长度 从大到小排一下序(当然从小到大也行),
然后观察重量的分类,也就是说,能够找到多少个从大到小的重量,

上代码:
/**
2015 - 09 - 30

Author: ITAK

Motto:

今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
**/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;

#define MM(a) memset(a,0,sizeof(a))

typedef long long LL;
typedef unsigned long long ULL;
const int maxn = 5000+5;
const int mod = 1000000007;
const double eps = 1e-7;
const double pi = 3.1415926;
const int e =  2.718281828;

struct node
{
    int l, w;
}arr[maxn];

int cmp(node a, node b)
{
    if(a.l != b.l)///按照长度从大到小排序
        return a.l > b.l;
    else///按重量排序
        return a.w > b.w;
}
int flag[maxn];
int main()
{
    int m, T;
    cin>>T;
    while(T--)
    {
        int ret = 0;
        cin>>m;
        for(int i=0; i<m; i++)
            cin>>arr[i].l>>arr[i].w;
        MM(flag);
        sort(arr, arr+m, cmp);
        for(int i=0; i<m; i++)
        {
            if(flag[i])
                continue;
            int Min = arr[i].w;///找到所有的从大到小排序的数。。。
            for(int j=i+1; j<m; j++)
            {
                if(Min>=arr[j].w && !flag[j])
                {
                    Min = arr[j].w;
                    flag[j] = 1;
                }
            }
            ret++;
        }
        cout<<ret<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值