poj1523割点&&块

SPF
Time Limit: 1000MS  Memory Limit: 10000K
Total Submissions: 2836  Accepted: 1262

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.


Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0
Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

 

 


#include<cstdio>
#include<iostream>
using namespace std;
//   freopen("data.in","r",stdin);

#include<cstring>
#define N 1005
bool G[N][N];
int _V;
int root;
bool vis[N];
int deep[N],ancestor[N];
bool cutP[N];
//int son[N];
int cutE[N][N];
void init()
{
    memset(G,0,sizeof(G));
    memset(cutP,0,sizeof(cutP));
  //  memset(son,0,sizeof(son));
    memset(deep,-1,sizeof(deep));
    memset(vis,0,sizeof(vis));
    _V=2;
    root=1;
}
void dfs(int u,int father,int d)
{

    deep[u]=ancestor[u]=d;
    int son=0;
    for(int v=1; v<=_V; v++)
    {
        if(G[u][v])
        {
            if(deep[v]==-1)
            {
                son++;
                dfs(v,u,d+1);
                ancestor[u]=ancestor[u]>ancestor[v]?ancestor[v]:ancestor[u];
            }
            else if(v!=father)
            {
                ancestor[u]=ancestor[u]>deep[v]?deep[v]:ancestor[u];
            }
        }
    }
    if(u==root)
    {
        if(son>1)cutP[root]=true;
        else cutP[root]=false;
    }
    else if(ancestor[u]>=deep[father])//
    {
        cutP[father]=true;
        cutE[father][u]=true;
    }
}

void output(int Case)
{
    printf("Network #%d\n",Case);
    bool exist=false;

    for(int u=1; u<=_V; u++)
    {
        if(cutP[u])
        {
            exist=true;
            int branch;
            if(u==1)branch=0;
            else branch=1;
            bool f=false;
            for(int v=1;v<=_V;v++)
            {
                if(G[u][v])
                {
                    if(ancestor[v]>deep[u])branch++;
                    if(ancestor[v]==deep[u])f=true;
                }
            }
            printf("  SPF node %d leaves %d subnets\n",u,branch+f);
        }
    }
    if(!exist)printf("  No SPF nodes\n");
    cout<<endl;
}
int main()
{
 //   freopen("data.in","r",stdin);
    int Case=1;
    int u,v;
    while(~scanf("%d",&u)&&u)
    {
        init();
        scanf("%d",&v);
        vis[u]=vis[v]=G[u][v]=G[v][u]=true;

        while(~scanf("%d",&u)&&u)
        {
            scanf("%d",&v);
            G[u][v]=G[v][u]=true;
            if(!vis[u])
            {
                vis[u]=true;
                _V++;
            }
            if(!vis[v])
            {
                vis[v]=true;
                _V++;
            }
        }

        dfs(1,0,0);

        output(Case);
        Case++;
    }
    return 0;
}


1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值