PTA-1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 题意:输入两个数,范围均在-10^6~10^6,从后往前按三个一组加逗号输出

做法:先转化成字符串,再从后往前标记逗号的位置,再从前往后打印。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string.h>
using namespace std;
int main()
{
    int a,b;
    scanf("%d %d",&a,&b);
    int sum = a + b;
    char str[1005];
    if(sum<0)//处理负数
    {
        printf("-");
        sum = -sum;
    }
    if(!sum)//处理结果为0的情况
    {
        printf("0");
        return 0;
    }
    int counts = 0;
    while(sum)
    {
        int temp = sum%10;
        str[counts] = temp + '0';
        counts ++;
        sum = sum/10;
    }
    int k[20] = {0};//标记逗号数组
   for(int i = 0; i < counts-1; i ++)
   {
       if((i+1)%3==0)
        k[i] = 1;
   }
   for(int i = counts - 1; i >= 0; i --)//打印
   {
       if(k[i])
        printf(",");
       printf("%c",str[i]);

   }
   return 0;

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值