闵浮龙的博客

一只忧郁的程序猿

ACTION REQUIRED: Dependencies libstdc++-6.dll and libgcc_s_seh-1.dll not found.

安装好了graphlab-create,但是,却不能成功导入graphlab模块。提示:
这里写图片描述
通过对这三点提示阅读,知道:第一,要确定D:\Anaconda2\envs\gl-env\lib\site-packages\graphlab文件有可写入的权限,我使用的win10的系统,在网上搜索如何在win10下设置文件夹的可写入权限,解决了这个问题。(因为,这一点问题不是主要问题,所以,就提一下。如果,你在此就解决了这个问题,那么恭喜你,不用再进行下一步的烦躁处理了。)

接着,看第二点。我们运行graphlab.get_dependencies()。之后,等待一会,如果成功还是恭喜你。如果没有,而是出现下面问题(或者一直停留在Downloading gcc-libs.):

那么,我们则还有接着进行下一步,因为,graphlab是用C来编写的,那么,在运行graphlab时,则需要gcc的编译。所以,我安装了gcc。

在网上百度有许多安装gcc的教程,我就不一一介绍。最后,记得将它添加环境变量。然后,重启电脑,我再次尝试导入graphlab模块,再运行graphlab.get_dependencies()。大约等待了10分钟左右。

阅读更多
个人分类: 感悟
想对作者说点什么? 我来说一句

python pandas库

2016年07月15日 5.6MB 下载

没有更多推荐了,返回首页

不良信息举报

ACTION REQUIRED: Dependencies libstdc++-6.dll and libgcc_s_seh-1.dll not found.

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭