zoj 3726& hdu 4791 Alice's Print Service

9 篇文章 0 订阅
5 篇文章 0 订阅

Alice's Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1298    Accepted Submission(s): 306


Problem Description
Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , ..., s n, p n (0=s 1 < s 2 < ... < s n ≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ ... ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 .. q m (0 ≤ q i ≤ 10 9 ) are the queries.
 

Output
For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.
 

Sample Input
  
  
1 2 3 0 20 100 10 0 99 100
 

Sample Output
  
  
0 1000 1000
 

Source
 

题意:给你n个s,p,然后让你查询m个s,求最低的打印钱,规则是si如果比si-1大但比si+1小则价格是pi-1。

做法:我是用线段树+二分做的,先对每个查询的值用二分求出它所在的价格的点b,然后在线段树上查询(b+1,n)上的最小值,两者比较取小值就是答案。还有一种方法就是先从后dp过来,把最小值保存在当前值中,然后直接二分出位置,然后比较这个点的价格和下一个点的价格,两者中的小值就是答案。

#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include<stack>
#include <set>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL long long
#define inf 0x0f0f0f0f
using namespace std;
LL n,m;
LL search2(LL array[], LL n, LL v)
{
    LL left, right, middle;

    left = 1, right = n;

    while (left <= right)
    {
        middle = (left + right) / 2;
        if (array[middle] > v)
        {
            right = middle - 1;
        }
        else if (array[middle] < v)
        {
            left = middle + 1;
        }
        else
        {
            return middle;
        }
    }

    return right;
}
struct Node
{
    LL left,right;
    LL sum;
};
Node T[100005<<2];
void build(LL cur,LL l,LL r)
{
    T[cur].left=l;
    T[cur].right=r;
    T[cur].sum=(1LL<<60);
    if(l!=r)
    {
        build(2*cur,l,(l+r)/2);
        build(2*cur+1,(l+r)/2+1,r);
    }
    else
    {
        return;
    }
}
LL query(LL cur,LL l,LL r)
{
    if(l<=T[cur].left&&T[cur].right<=r)
        return T[cur].sum;
    else
    {
        LL ans=(1LL<<60);
        if(l<=(T[cur].left+T[cur].right)/2)
            ans=min(ans,query(2*cur,l,r));
        if(r>(T[cur].left+T[cur].right)/2)
            ans=min(ans,query(2*cur+1,l,r));
        return ans;
    }
}
void change(LL cur,LL x,LL del)
{
    if(T[cur].left==T[cur].right)
        T[cur].sum=del;
    else
    {
        if(x<=(T[cur].left+T[cur].right)/2)
            change(2*cur,x,del);
        if(x>(T[cur].left+T[cur].right)/2)
            change(2*cur+1,x,del);
        T[cur].sum=min(T[2*cur].sum,T[2*cur+1].sum);
    }
}
struct wupin
{
    LL s;
    LL p;
}w[100005];
int main()
{
    LL t;
    LL i,j;
    LL ans;
    scanf("%I64d",&t);
    while(t--)
    {
        scanf("%I64d%I64d",&n,&m);
        LL ss[100005];
        build(1,1,n);
        for(i=1;i<=n;i++)
        {
            scanf("%I64d%I64d",&w[i].s,&w[i].p);
            ss[i]=w[i].s;
            change(1,i,w[i].s*w[i].p);
        }
        while(m--)
        {
            LL a,b;
            scanf("%I64d",&a);
            b=search2(ss,n,a);
            ans=a*w[b].p;
            if(b+1<=n)
            ans=min(ans,query(1,b+1,n));
            printf("%I64d\n",ans);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值