Common Subsequence HDU dp

http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?pid=1010&ojid=0&cid=3967

Common Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 6
Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.


 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp


 

Sample Output
  
  
4 2 0
 
#include<cstdio>
#include<cstring>
using namespace std;
int dp[1001][1001];
int main()
{
    char pre[1001];
    char pos[1001];
    while(scanf("%s%s",pre,pos)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        int l1=strlen(pre);
        int l2=strlen(pos);
        for(int i=0; i<l1; i++)
        {
            for(int j=0; j<l2; j++)
            {
                if(pre[i]==pos[j])
                    dp[i+1][j+1]=dp[i][j]+1;
                else  if(dp[i+1][j]>dp[i][j+1])
                    dp[i+1][j+1]=dp[i+1][j];
                else
                    dp[i+1][j+1]=dp[i][j+1];
            }
        }
        printf("%d\n",dp[l1][l2]);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值