PAT 1056 Mice and Rice (25point(s))(队列的使用)

21 篇文章 0 订阅
20 篇文章 1 订阅

1056 Mice and Rice (25point(s))

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

 

 

题意:

每人一只老鼠,共有Np个人

每Ng个人一组,胜利者进入下一轮,失败者排名相同

每Ng个胜利者组成一个新的组,进入下一轮比赛,重复直到找到最后一个胜利者

输入所有【老鼠的权重】,【初始化参赛者顺序】,输出排名

思路:

 可以理解成是淘汰赛简单版,参赛者一层一层向上pk,直到出现最后胜利者

我们可以用一个变量level模拟这个一层一层,开始时候,level=1,晋级者的level+=1,直到出现最后的胜利者

然后根据level排序,计算出排名

输出结果

#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<algorithm>
#include<string>
#include<map>
#include<unordered_map>
#include<string.h>
#include<vector>
#include<queue>
#include<stack>
using namespace std;
typedef long long ll;
#define maxn 10009

struct Programmer {
	int id;
	int rank;
	int level;
	double weight;
};
vector<Programmer> prog;
vector<int> vec;//用于记录当前一轮参赛者编号
queue<int> que;//用于保存当前轮晋级者,方便下一轮使用

bool cmp(Programmer x, Programmer y) {//根据level排序
	return x.level > y.level;
}

bool cmpById(Programmer x, Programmer y) {//根据输入顺序id排序
	return x.id < y.id;
}
int main() {
	int ng, np, order;
	double weight;
	int idx;
	cin >> np >> ng;
	vec.resize(np);
	prog.resize(np);
	for (int i = 0; i < np; i++) {
		cin >> prog[i].weight;
		prog[i].id = i;//记录下输入顺序,方便后面排序
		prog[i].level = 1;//初始化level=1
	}
	//输入比赛入场顺序
	for (int i = 0; i < np; i++) {
		cin >> order;
		que.push(order);
	}

	while (que.size() != 1) {
		//把que中的参数者入场(即放进vec)
		vec.clear();
		while (!que.empty()) {
			vec.push_back(que.front());//记录参与比赛的prog的下标
			que.pop();
		}
		for (int i = 0; i < vec.size(); i += ng) {
			//找出参赛者最胖老鼠的vec下标idx
			weight = prog[vec[i]].weight;
			idx = i;
			for (int j = 1; j < ng &&i + j < vec.size(); j++) {
				if (prog[vec[i + j]].weight > weight) {
					idx = i + j;
					weight = prog[vec[i + j]].weight;
				}
			}
			prog[vec[idx]].level++;//level++,晋级
			que.push(vec[idx]);//晋级者放进队列,准备进入下一轮比赛
		}
	}
	sort(prog.begin(), prog.end(), cmp);//level 越高排名越前
	//记录排名
	int rank = 1;
	for (int i = 0; i < np; i++) {
		if (i > 0 && prog[i].level == prog[i - 1].level) {
			prog[i].rank = prog[i-1].rank;
		}
		else {
			prog[i].rank = rank;
		}
		rank++;
	}
	sort(prog.begin(), prog.end(), cmpById);//恢复顺序
	for (int i = 0; i < np; i++) {
		printf("%d", prog[i].rank);
		if (i != np - 1)printf(" ");
		else printf("\n");
	}

	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值