JAVA -- Java compiler level does not match the version of the installed Java project facet.

问题描述:加载新的项目后报一个错误:

Java compiler leveldoes not match the version of the installed Java project facet.

 

问题分析:

java版本不匹配:FactedProject 中的Java 版本设定与项目的Java 版本设定不一致。

 

解决方案:

在当前项目上点右键,属性--ProjectFacets中,配置编译版本与java

compiler的版本一致。

1、选中项目后按下alt+enter组合键或者右键Project

| Properties | JavaCompiler(type filter text输入compiler可快速定位),如下图所示:


2、修改ProjectFacets的Java值,使之和Compiler compliance level相同:打开方式参考1,如下图:

 



3.到项目下的.settings(D:\execWork\workspace\ReportAndDataServices\.settings)中的org.eclipse.wst.common.project.facet.core.xml文档中的Java版本,将其修改一致,如图


阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq814965130/article/details/79256900
文章标签: JAVA
个人分类: JAVA
上一篇JAVA -- POI导出excel
下一篇JAVA -- ant编译时出现Compile failed; see the compiler error output for details异常
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭