hdu-1042-N!(大数)

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54232    Accepted Submission(s): 15394


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
代码:
#include<stdio.h>
#include<string.h>
#define MAX 50000//数组要开合适,开到10000会wrong!!!! 开到1000000会超时!!!!!
int a[MAX];
int main()
{
   int n;
   while(~scanf("%d",&n))
   {
        memset(a,0,sizeof(a));
        a[0]=1;
        int i,j,d,c=0;
        for(i=2;i<=n;++i)
        {   c=0;
            for(j=0;j<MAX;++j)
            {
                d=a[j]*i+c;
                a[j]=d%10;
                c=d/10;
            }
        }
        while(c)
        {
            a[j++]=c%10;
            c=c/10;
        }
        for(j=MAX-1;j>0;--j)
        if(a[j]!=0)
        break;
        for(;j>=0;--j)
        printf("%d",a[j]);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值