NYOJ-A+B Problem II

A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:112233445566778899 + 998877665544332211 = 1111111111111111110

代码:
#include<stdio.h>
#include<string.h>
char a[1010],b[1010];
int s1[1010],s2[1010];
int sum[1010];
int main()
{
	int T,k=0,i,j,d,c;
	scanf("%d",&T);
	while(T--)
	{
		memset(s1,0,sizeof(s1));
		memset(s2,0,sizeof(s2));
		memset(sum,0,sizeof(sum));
		k++;
		scanf("%s %s",a,b);
		int len1,len2;
		len1=strlen(a);
		len2=strlen(b);
		for(i=len1-1,j=0;i>=0;--i,++j)
		s1[j]=a[i]-'0';
		for(i=len2-1,j=0;i>=0;--i,++j)
		s2[j]=b[i]-'0';
		c=0;
		for(i=0;i<len1||i<len2;++i)
		{
			d=s1[i]+s2[i]+c;
			sum[i]=d%10;
			c=d/10;
		}
		printf("Case %d:\n",k);
		printf("%s + %s = ",a,b);
		if(c)
		sum[i++]=c;
		for(;i>0;--i)
		if(sum[i])
		break;
		for(;i>=0;--i)
		printf("%d",sum[i]);
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值