hdoj-1069-Monkey and Banana【动态规划】

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9489 Accepted Submission(s): 4927


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342

Source

Recommend

JGShining | We have carefully selected several similar problems for you: 1058 1024 1171 1421 1074


WA了 9次,也是醉了!!!!!动态规划还是需要多练习,其次以后再碰到WA后,要积极的找未考虑的测试数据,而不是盲目的乱修改

给组测试数据: 1

                              10 10 20

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int INF=1<<28;
struct block{
	int x,y,z;
}b[1000];
int dp[1100];
int cmp(block a,block b){
	if(a.y!=b.y) return a.y>b.y;
	else  if(a.x!=b.x) return a.x>b.x;
	return a.z>b.z;
}
int main(){
	int n,cas=0;
	while(~scanf("%d",&n),n){
		cas++;
		int i,j,k,aa,bb,cc;
		for(i=1,k=1;i<=n;++i){
			scanf("%d%d%d",&aa,&bb,&cc);
			b[k].x=max(aa,bb);
			b[k].y=min(aa,bb);
			b[k++].z=cc;
			b[k].x=max(aa,cc);
			b[k].y=min(aa,cc);
			b[k++].z=bb;
			b[k].x=max(bb,cc);
			b[k].y=min(bb,cc);
			b[k++].z=aa;
		}
		memset(dp,0,sizeof(dp));
		b[0].x=b[0].y=b[0].z=INF;  <span style="color:#33ffff;"> <span style="background-color: rgb(255, 255, 255);">// 将 最下面的block想象为无限大的地面,高度为 0 之前就是在此处 WA 的,存的有效数据从b[0]开始的,直接把dp[0]=排过序后的第一个,即: dp[0] = a[0].z;实际上若是上面给的那个测试数据 ,会默认为dp[0]=10,事实上我们知道应该是20的</span></span>
		sort(b,b+k,cmp);       
		
		dp[0]=0;
		int ans=0;
		for(i=1;i<k;++i){
           for(j=0;j<i;++j){
           	if(b[j].x>b[i].x&&b[j].y>b[i].y)
             dp[i]=max(dp[i],dp[j]+b[i].z); 
           } 
           ans=max(ans,dp[i]);
		}
	    printf("Case %d: maximum height = %d\n",cas,ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值