Count the Colors

B - Count the Colors
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input



The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output



Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input



5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output



1 1
2 1
3 1

1 1

0 2
1 1


/*
Author: 2486
Memory: 232 KB		Time: 110 MS
Language: C++ (g++ 4.7.2)		Result: Accepted
*/
//暴力可过,或者是线段树
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef long long ll;
using namespace std;
const int maxn=8000+5;
int n,a,b,c,ans[maxn],col[maxn];
int main() {
    while(~scanf("%d",&n)) {
        memset(ans,0,sizeof(ans));
        memset(col,0,sizeof(col));
        int Max=0;
        for(int i=0; i<n; i++) {
            scanf("%d%d%d",&a,&b,&c);
            for(int j=a; j<b; j++) {
                col[j]=c+1;
            }
            Max=max(Max,b);
        }
        for(int i=0; i<=Max; i++) {
            while(i!=0&&col[i]&&col[i]==col[i-1]) {
                i++;
            }
            if(col[i]) {
                ans[col[i]-1]++;
            }
        }
        for(int i=0; i<=8001; i++) {
            if(ans[i]) {
                printf("%d %d\n",i,ans[i]);
            }
        }
        printf("\n");
    }
}
/*
Author: 2486
Memory: 356 KB		Time: 20 MS
Language: C++ (g++ 4.7.2)		Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=8000+5;
int sum[maxn],col[maxn<<2],res[maxn];
int n,x1,x2,c;
void pushup(int rt) {}
void pushdown(int rt,int l,int r) {
    if(col[rt]!=-1) {
        col[rt<<1]=col[rt<<1|1]=col[rt];//直接往下递归就可以了,不用管其他
        col[rt]=-1;
    }
}
void build(int rt,int l,int r) {
    col[rt]=-1;
    if(l==r)return;
    int mid=(l+r)>>1;
    build(rt<<1,l,mid);
    build(rt<<1|1,mid+1,r);
}
void update(int L,int R,int c,int rt,int l,int r) {
    if(L<=l&&r<=R) {
        col[rt]=c;
        return;
    }
    pushdown(rt,l,r);
    int mid=(l+r)>>1;
    if(L<=mid)update(L,R,c,rt<<1,l,mid);
    if(mid<R)update(L,R,c,rt<<1|1,mid+1,r);
    pushup(rt);
}
void query(int L,int R,int rt,int l,int  r) {
    if(l==r) {
        sum[l]=col[rt];//赋值,放回区间的位子颜色
        return;
    }
    pushdown(rt,l,r);
    int mid=(l+r)>>1;
    if(L<=mid)query(L,R,rt<<1,l,mid);
    if(mid<R)query(L,R,rt<<1|1,mid+1,r);
    pushup(rt);
}
int main() {
    while(~scanf("%d",&n)) {
        memset(sum,-1,sizeof(sum));
        memset(res,0,sizeof(res));
        build(1,0,maxn-1);
        for(int i=0; i<n; i++) {
            scanf("%d%d%d",&x1,&x2,&c);
            if(x1==x2)continue;
            update(x1,x2-1,c,1,0,maxn-1);
        }
        query(0,maxn-1,1,0,maxn-1);//将所有数据都更新到底部
        for(int i=0; i<maxn; i++) {
            while(i!=0&&sum[i]!=-1&&sum[i]==sum[i-1])//如果没有颜色就加一,如果与之前相等那么也是加一
                i++;
            res[sum[i]]++;
        }
        for(int i=0; i<maxn; i++)if(res[i])printf("%d %d\n",i,res[i]);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Let 𝑃 be a set of 𝑛 points on the 𝑥-axis and each of the points is colored with one of the colors 1,2, . . . , 𝑘. For each color 𝑖 of the 𝑘 colors, there is at least one point in 𝑃 which is colored with 𝑖. For a set 𝑃 ′ of consecutive points from 𝑃, if both 𝑃 ′ and 𝑃 ∖ 𝑃 ′ contain at least one point of each color, then we say that 𝑃 ′ makes a double rainbow. See the below figure as an example. The set 𝑃 consists of ten points and each of the points is colored by one of the colors 1, 2, 3, and 4. The set 𝑃 ′ of the five consecutive points contained in the rectangle makes a double rainbow. Given a set 𝑃 of points and the number 𝑘 of colors as input, write a program that computes and prints out the minimum size of 𝑃 ′ that makes a double rainbow. Input Your program is to read from standard input. The input starts with a line containing two integers 𝑛 and 𝑘 (1 ≤ 𝑘 ≤ 𝑛 ≤ 10,000), where 𝑛 is the number of the points in 𝑃 and 𝑘 is the number of the colors. Each of the following 𝑛 lines consists of an integer from 1 to 𝑘, inclusively, and the 𝑖-th line corresponds to the color of the 𝑖-th point of 𝑃 from the left. Output Your program is to write to standard output. Print exactly one line. The line should contain the minimum size of 𝑃 ′ that makes a double rainbow. If there is no such 𝑃 ′ , print 0. The following shows sample input and output for two test cases.
最新发布
07-23

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值