poj 3187I - 开心与不开心一一细数着你再不舍 【全排列】

I - 开心与不开心一一细数着你再不舍
Crawling in process... Crawling failed Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:       

    3   1   2   4 
 4   3   6 
 7   9 
 16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.       

Write a program to help FJ play the game and keep up with the cows.     

Input

Line 1: Two space-separated integers: N and the final sum.     

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.     

Sample Input

4 16

Sample Output

3 1 2 4
分析:
直接暴力,所有的全排列数据一个一个试。
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
using namespace std;
int pp[110];
int gg[110][110];
int n,m;

void init()
{
	memset(pp,0,sizeof(pp));
	memset(gg,0,sizeof(gg));
	for(int i=0;i<=n;i++)
	pp[i]=i;
}

bool judge()
{
   for(int i=1;i<=n;i++)
   gg[1][i]=pp[i];
   for(int i=2;i<=n;i++)
     for(int j=i;j<=n;j++ )
     {
     	gg[i][j]=gg[i-1][j]+gg[i-1][j-1];
     }
     if(gg[n][n]==m)
     return true;
     else return false;
}

void solve(int kk)
{
	while(kk--)
	{
		next_permutation(pp+1,pp+n+1);
		if(judge())
		{
			for(int i=1;i<=n-1;i++)
			{
			printf("%d ",pp[i]);
		}
		printf("%d\n",pp[n]);
		break;
		}
	}
}

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		int kk=1;
		for(int i=1;i<=n;i++)
		kk*=i;
		solve(kk);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值