PAT甲级1110

1110. Complete Binary Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:
NO 1

#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn = 30;
struct node
{
	int data, lchild, rchild;
	node():lchild(-1),rchild(-1){}
}nodes[maxn];
bool notroot[maxn] = { false };
int main()
{
	int N;
	scanf("%d", &N);
	char l[3], r[3];
	for (int i = 0; i < N; i++)
	{
		scanf("\n%s %s", l, r);//注意将之前的换行符吸收掉
		nodes[i].data = i;//注意下标可能是两位数,不能只用一个字符储存!!!!
		if (l[0] != '-')
		{
			nodes[i].lchild = atoi(l);
			notroot[atoi(l)] = true;
		}
		if (r[0] != '-')
		{
			nodes[i].rchild = atoi(r);
			notroot[atoi(r)] = true;
		}
	}
	int root;
	for (int i = 0; i < N; i++)
	{
		if (!notroot[i])
		{
			root = i;
			break;//找根
		}
	}
	queue<node> Q;
	Q.push(nodes[root]);
	int last=root; int count = 1;
	while (!Q.empty())
	{
		node nd = Q.front();
		Q.pop();
		if (nd.lchild != -1)
		{
			Q.push(nodes[nd.lchild]);
			count++;
			last = nd.lchild;
		}
		else
			break;
		if (nd.rchild != -1)
		{
			Q.push(nodes[nd.rchild]);
			count++;
			last = nd.rchild;
		}
		else
			break;
	}
	if (count == N)
		printf("YES %d\n", last);
	else
		printf("NO %d\n", root);
	return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值