Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : 'digest'

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_24452475/article/details/82996212

α 写在前面


β 问题描述

  • 基于Jupyter,R语言开发过程中,通过 install.packages('xxxx') 命令安装某些包后,R内核启动失败。
    • 具体异常如下所示:
      [W 13:45:25.693 NotebookApp] 404 GET /api/kernels/f729993b-f6da-4a05-95eb-16c3b82e99b2/channels?session_id=288c20f6eee8436588648d7d224c213c (::1): Kernel does not exist: f729993b-f6da-4a05-95eb-16c3b82e99b2
      [W 13:45:25.699 NotebookApp] 404 GET /api/kernels/f729993b-f6da-4a05-95eb-16c3b82e99b2/channels?session_id=288c20f6eee8436588648d7d224c213c (::1) 15.20ms referer=None
      [I 13:45:37.940 NotebookApp] Creating new notebook in
      [I 13:45:38.708 NotebookApp] Kernel started: ed892fca-898e-44b0-ba2e-6145d309b3ac
      Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
        'digest'
      Calls: :: ... tryCatch -> tryCatchList -> tryCatchOne -> <Anonymous>
      

γ 解决方案

  • 通过console 切换到 IRkernel 目录,执行 ../bin/x64/Rgui.exe 。通过弹出的 RGui 安装 digest 包,如下图所示:
    在这里插入图片描述

  • 根据RGui控制台提示,如果相关包都安装成功,则 R 内核可以正常使用。

  • 目录对应关系

    • IRkernel (Everything 工具搜索)路径
      • D:\ProgramData\Anaconda3\Lib\R\library
    • RGui 路径
      • D:\ProgramData\Anaconda3\Lib\R\bin\x64\Rgui.exe

δ 测试代码

  •   install.packages('ggplot2')  # 安装 ggplot2 包
      install.packages('WDI')  # 安装 WDI 包
      
      options(repr.plot.width=7, repr.plot.height=5)
      library(WDI) 
      library(ggplot2)
      
      # 获取数据
      
      dat <- WDI(indicator='NY.GNP.PCAP.CD', 
                country=c('CL','HU','UY'), start=1960, end=2012) 
      p <- ggplot(dat, aes(year, NY.GNP.PCAP.CD, color=country)) + 
                 geom_line() +
                  xlab('Year') + 
                  ylab('GDI per capita (Atlas Method USD)') +
                  labs(title <- "GNI Per Capita ($USD Atlas Method)")
      p
    
  • 测试效果
    result

ε 补充

  • 列出所有已安装包
    pkgs <- sort(.packages(all.available = TRUE))
    length(pkgs)
    pkgs
    
  • 安装 XXX 包并自动安装依赖包
    • 方式 1
      install.packages("ggplot2", dependencies = TRUE)
      
    • 方式 2
       install.packages("ggplot2", repos="http://cran.rstudio.com/", dependencies=TRUE)
      
    • 方式 3
       # 通过如下命令设定镜像
      options(repos = 'http://mirrors.ustc.edu.cn/CRAN/')
      # 查看镜像是否修改
      getOption('repos')
      # 尝试下载R包
      install.packages('ggplot2')
      
  • 注释
    • 差点儿就删除重装了,一开始真闹心,Windows 10 下搜索出来好多个 R,不过 还好最终锁定了 IRkernel 下的 R,铜鼓 RGui 安装对应包后,问题得到了有效解决。
    • 通过 eclipse 进行 R语言的开发, 有点儿闹心,甚至有了想放弃学习 R 语言的念头,不过通过 Jupyter 进行R 语言开发感觉容易很多。
    • 作为开发者,真心不能固步自封,不然很容错过太多太多有意思的事情!
阅读更多
换一批

没有更多推荐了,返回首页