HDU 1241 Oil Deposits【简单DPS搜索】

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23239    Accepted Submission(s): 13408


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2


题意:

找属于同一脉矿的油田有多少个,同一个脉矿的意思是 ’@‘ 的相邻八个方向如果有 ’@‘ 标记,则是同一个脉矿

题解:

一个个找,从第一个@开始DPS搜索,相邻的就标记为‘+’,搜索完跳出DPS之后,就找出了一个的脉矿,统计总共的个数


#include<stdio.h>
#include<string.h>
char maze[110][110];
int n,m;
void DPS(int x,int y);
int main (void)
{

    while(~scanf("%d%d",&n,&m),n||m)
    {
        memset(maze,'0',sizeof(maze));
        getchar();//注意 字符输入  吃掉上次组测试的回车 
        for(int i=1;i<=n;i++)
        {
            for(int ii=1;ii<=m;ii++)
            {
                scanf("%c",&maze[i][ii]);
            }
            getchar();
        }
        int num=0;
        for(int i=1;i<=n;i++)
        {
            for(int ii=1;ii<=m;ii++)
            {
                if(maze[i][ii]=='@')
                {
                    DPS(i,ii);
                    ++num;
                }
            }
        }
        printf("%d\n",num);
    }
    return 0;
}
void DPS(int x,int y)
{
   // printf("x=%d  y=%d map[x][y]=%c\n",x,y,maze[x][y]);
    if(x>n||x<=0||y>m||y<=0) return ;
    else if(maze[x][y]=='*') return ;
    else if(maze[x][y]=='+') return ;
    maze[x][y] = '+';
    DPS(x-1,y-1);
    DPS(x-1,y  );
    DPS(x-1,y+1);
    DPS(x  ,y-1);
    DPS(x  ,y+1);
    DPS(x+1,y-1);
    DPS(x+1,y  );
    DPS(x+1,y+1);
}
/*
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
*/

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值