ADD1 小白书5.1 C - Automatic Poetry

                                    10361 Automatic Poetry
“Oh God”, Lara Croft exclaims, “it’s one of these dumb riddles again!”
In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric
caves and medival hallways. Now she is standing in front of some important Germanic looking
doorway and has to solve a linguistic riddle to pass. As usual, the riddle is not very intellectually
challenging.
This time, the riddle involves poems containing a “Schuttelreim”. An example of a Schuttelreim is
the following short poem:
Ein Kind halt seinen Schnabel nur,
wenn es hangt an der Nabelschnur.
Note: German users, please, forgive me. I had to modify something as they were not appearing
correctly in plain text format
A Schuttelreim seems to be a typical German invention. The funny thing about this strange type
of poetry is that if somebody gives you the first line and the beginning of the second one, you can
complete the poem yourself. Well, even a computer can do that, and your task is to write a program
which completes them automatically. This will help Lara concentrate on the “action” part of Tomb
Raider and not on the “intellectual” part.
Input
The input will begin with a line containing a single number n. After this line follow n pairs of lines
containing Schuttelreims. The first line of each pair will be of the form
s1<s2>s3<s4>s5
where the si are possibly empty, strings of lowercase characters or blanks. The second line will be
a string of lowercase characters or blanks ending with three dots ‘...’. Lines will we at most 100
characters long.
Output
For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way:
c1 is the same as l1 only that the bracket marks ‘<’ and ‘>’ are removed. Line c2 is the same as l2 ,
except that instead of the three dots the string s4s3s2s5 should appear.
Sample Input
3
ein kind haelt seinen <schn>abel <n>ur
wenn es haengt an der ...
weil wir zu spaet zur <>oma <k>amen
verpassten wir das ...
<d>u <b>ist
...
Universidad de Valladolid OJ: 10361 – Automatic Poetry 2/2
Sample Output
ein kind haelt seinen schnabel nur
wenn es haengt an der nabel schnur
weil wir zu spaet zur oma kamen
verpassten wir das koma amen
du bist

bu dist



简单来说这道题就是要输入两行字符串,第一行字符串中含有两对<>,输出的第一行就是输入的第一行字符串去掉<>后的结果,这个不难做到,输入的第二行字符串中含有“...”,需要我们从输入的第一行字符串中的字符补齐,具体的补齐方法就是交换两个<>内的内容,然后连接到第二个字符串中,再输出。


程序的代码如下:

#include<stdio.h>  
#include<string.h>  
int main ()  
{  
    int i,n;  
    char c,str1[500],str2[81],str3[81],str4[81],str5[81],str[100];  
    scanf("%d",&n);  
    getchar();         //读取并忽略n
    while(n--)  
    {  
    for(i=0;(c=getchar())!='<';i++)  
    str1[i]=c;  
    str1[i] = '\0';  
    for(i=0;(c=getchar())!='>';i++)  
    str2[i]=c;  
    str2[i] = '\0';  
    for(i=0;(c=getchar())!='<';i++)  
    str3[i]=c;  
    str3[i] = '\0';  
    for(i=0;(c=getchar())!='>';i++)  
    str4[i]=c;  
    str4[i] = '\0';  
    for(i=0;(c=getchar())!='\n';i++)  
    str5[i]=c;  
    str5[i] = '\0';  
    gets(str);  
    str[strlen(str)-3]='\0';  
    printf("%s%s%s%s%s\n", str1, str2, str3, str4, str5);  
    printf("%s%s%s%s%s\n", str, str4, str3, str2 ,str5);  
                       
    }  
    return 0;  
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值