POJ 2028 When Can We Meet?(模拟)

When Can We Meet?

Description

The ICPC committee would like to have its meeting as soon as possible to address every little issue of the next contest. However, members of the committee are so busy maniacally developing (possibly useless) programs that it is very difficult to arrange their schedules for the meeting. So, in order to settle the meeting date, the chairperson requested every member to send back a list of convenient dates by E-mail. Your mission is to help the chairperson, who is now dedicated to other issues of the contest, by writing a program that chooses the best date from the submitted lists. Your program should find the date convenient for the most members. If there is more than one such day, the earliest is the best.

Input

The input has multiple data sets, each starting with a line containing the number of committee members and the quorum of the meeting. 

N Q 
Here, N, meaning the size of the committee, and Q meaning the quorum, are positive integers. N is less than 50, and, of course, Q is less than or equal to N. 

N lines follow, each describing convenient dates for a committee member in the following format. 

M Date1 Date2 ... DateM 
Here, M means the number of convenient dates for the member, which is an integer greater than or equal to zero. The remaining items in the line are his/her dates of convenience, which are positive integers less than 100, that is, 1 means tomorrow, 2 means the day after tomorrow, and so on. They are in ascending order without any repetition and separated by a space character. Lines have neither leading nor trailing spaces. 

A line containing two zeros indicates the end of the input. 

Output

For each data set, print a single line containing the date number convenient for the largest number of committee members. If there is more than one such date, print the earliest. However, if no dates are convenient for more than or equal to the quorum number of members, print 0 instead.

Sample Input

3 2
2 1 4
0
3 3 4 8
3 2
4 1 5 8 9
3 2 5 9
5 2 4 5 7 9
3 3
2 1 4
3 2 5 9
2 2 4
3 3
2 1 2
3 1 2 9
2 2 4
0 0

Sample Output

4
5
0
2
题目大意:有N个人要参加会议,然而他们都很忙,每个人的空闲时间都不一样,给出要求参加会议的最少人数和每个人的空闲时间,求出能使参加会议人数最多的日期,如果有多个这样的日期,输出最早的日期;如果没有一个日期能够达到人数要求,输出0。

解题思路:使用数组记录每个日期空闲的人数,然后查询满足条件的日期输出即可。(做一下水题,找回一点信心。。。)

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int maxn = 105;
int data[maxn];
int n,q,m;

int main()
{
	int i,j,k;
	while(scanf("%d %d",&n,&q) != EOF && (n || q)){
		memset(data,0,sizeof(data));
		int len = 0;
		for(i = 0;i < n;i++){
			scanf("%d",&m);
			for(j = 0;j < m;j++){
				scanf("%d",&k);
				len = max(len,k);
				data[k]++;
			}
		}
		bool flag = false;
		for(j = n;j >= q;j--){//先检查满足q的最大值,其次是次大值,最后检查q 
			for(i = 1;i <= len;i++){
				if(data[i] >= j){
					flag = true;
					break;
				}
			}
			if(flag)
				break;
		}
		printf("%d\n",flag == true ? i : 0);
	}
	return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值