POJ 2485 Highways(最小生成树)

Highways

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692
题目大意:有一个小岛上面有许多村庄,村庄之间要修路,现在给出一个矩阵,第i行j列的元素代表村庄i与村庄j之家的距离。求一个修路方案,使得所有村庄连通且最长的道路最短。

解题思路:题目看了半天没看懂什么意思,仔细一看发现就是求最小生成树然后输出最后一条被加到树里的边,因为边已经排好序了,所以最小生成树的最后一条边肯定是符合条件的。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MEM(arr,val) memset(arr,val,sizeof(arr))
const int maxn = 250005;
int par[maxn],rank[maxn];
int n,cnt;
struct edge
{
    int from;
    int to;
    int cost;
};
edge edges[maxn];

bool cmp(edge a,edge b)
{
    return a.cost < b.cost;
}

void init()
{
    for(int i = 1;i <= maxn;i++)
        par[i] = i;
    MEM(rank,0);
}

int find(int x)
{
    return par[x] ==  x ? x : par[x] = find(par[x]);
}

void unite(int x,int y)
{
    x = find(x);
    y = find(y);
    if(x == y)
        return ;
    if(rank[x] < rank[y])
        par[x] = y;
    else{
        par[y] = x;
        if(rank[x] == rank[y])
            rank[x]++;
    }
}

bool same(int x,int y)
{
    return find(x) == find(y);
}

int Kruskal()
{
    init();
    std::sort(edges + 1,edges + cnt,cmp);
    int res = 0;
    for(int i = 1;i < cnt;i++){
        edge e = edges[i];
        if(!same(e.from,e.to)){
            unite(e.from,e.to);
            res = e.cost;
        }
    }
    return res;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        int x;
        cnt = 0;
        for(int i = 1;i <= n;i++){
            for(int j = 1;j <= n;j++){
                scanf("%d",&x);
                edges[cnt].from = i;
                edges[cnt].to = j;
                edges[cnt].cost = x;
                cnt++;
            }
        }
        printf("%d\n",Kruskal());
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值