POJ 1724 ROADS(BFS + 优先队列)


ROADS

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find  the shortest path from the city 1 to the city N  that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11
题目大意:给出一个有向图,边上有两个权值,分别是距离和花费。求一条从1到N的最短路,使得总花费小于等于k。

解题思路:这道题是出现在最短路的练习里,结果用BFS + 优先队列水过了。node里面保存的是当前节点的标号,所走过的距离以及已经花费的钱数。初始时(1,0,0)入队,表示在1号点,走了0距离,总花费为0。然后根据给出的图BFS即可,注意条件判断。

代码如下:

#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
#include <cstring>
#include <bits/stdc++.h>
#define MEM(arr,val) memset(arr,val,sizeof(arr))
const int maxm = 10005;//roads
const int maxn = 105;//cities
using namespace std;
struct road
{
    int to;
    int dis;
    int cost;
    road(int to,int dis,int cost)
    {
        this -> to = to;
        this -> dis = dis;
        this -> cost = cost;
    }
};
struct node
{
    int id;
    int dis;
    int used;
    node(int id,int dis,int used)
    {
        this -> id = id;
        this -> dis = dis;
        this -> used = used;
    }
    bool operator < (const node& a)const
    {
        return a.dis == dis ? a.used > used : dis > a.dis;
    }
};
int k,n,r,d[maxn];
vector<road> G[maxn];
priority_queue<node> que;
void init()
{
    for(int i = 0;i < maxn;i++)
        G[i].clear();
}

void add_edge(int from,int to,int dis,int cost)
{
    G[from].push_back(road(to,dis,cost));
}

int bfs()
{
    while(que.size())
        que.pop();
    que.push(node(1,0,0));
    while(que.size()){
        node p = que.top();
        que.pop();
        if(p.id == n)
            return p.dis;
        for(int i = 0;i < (int)G[p.id].size();i++){
            road rd = G[p.id][i];
            if(k - p.used < rd.cost)
                continue;
            que.push(node(rd.to,rd.dis + p.dis,p.used + rd.cost));
        }
    }
    return -1;
}
int main()
{
    init();
    scanf("%d %d %d",&k,&n,&r);
    int from,to,dis,cost;
    while(r--){
        scanf("%d %d %d %d",&from,&to,&dis,&cost);
        add_edge(from,to,dis,cost);
    }
    printf("%d\n",bfs());
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值