POJ 2612 Mine Sweeper 扫雷游戏

原题 http://poj.org/problem?id=2612

题目:

Mine Sweeper
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6638 Accepted: 2564
Description

The game Minesweeper is played on an n by n grid. In this grid are hidden m mines, each at a distinct grid location. The player repeatedly touches grid positions. If a position with a mine is touched, the mine explodes and the player loses. If a positon not containing a mine is touched, an integer between 0 and 8 appears denoting the number of adjacent or diagonally adjacent grid positions that contain a mine. A sequence of moves in a partially played game is illustrated below.

Here, n is 8, m is 10, blank squares represent the integer 0, raised squares represent unplayed positions, and the figures resembling asterisks represent mines. The leftmost image represents the partially played game. From the first image to the second, the player has played two moves, each time choosing a safe grid position. From the second image to the third, the player is not so lucky; he chooses a position with a mine and therefore loses. The player wins if he continues to make safe moves until only m unplayed positions remain; these must necessarily contain the mines.

Your job is to read the information for a partially played game and to print the corresponding board.
Input

The first line of input contains a single postitive integer n <= 10. The next n lines represent the positions of the mines. Each line represents the contents of a row using n characters: a period indicates an unmined positon while an asterisk indicates a mined position. The next n lines are each n characters long: touched positions are denoted by an x, and untouched positions by a period. The sample input corresponds to the middle figure above.
Output

Your output should represent the board, with each position filled in appropriately. Positions that have been touched and do not contain a mine should contain an integer between 0 and 8. If a mine has been touched, all positions with a mine should contain an asterisk. All other positions should contain a period.
Sample Input

8
*..
……*.
….*…
……..
……..
…..*..
*..
…..*..
xxx…..
xxxx….
xxxx….
xxxxx…
xxxxx…
xxxxx…
xxx…..
xxxxx…
Sample Output

001…..
0013….
0001….
00011…
00001…
00123…
001…..
00123…

思路:

扫雷的玩法就是翻数寻雷,翻出来的数是1代表周围的八个格子有1个雷,2代表有2个,等等。
逆向思维的结果就是每个雷周围有8个1,当两个雷有相邻的时候,数字可以叠加。
简单的遍历就可以求出结果。不太清楚的可以去玩几把。
注意:点到雷的时候所有雷都是会显示的。

代码:

#include <iostream>
#include"string.h"
#include"cstdio"
#include"stdlib.h"
#include"algorithm"

using namespace std;
typedef long long int lint;
const int bc=12;
char tu[bc][bc];
char flag[bc][bc];
char antu[bc][bc];
int ans[bc][bc];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        getchar();
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                scanf("%c",&tu[i][j]);
            }
            getchar();
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                scanf("%c",&flag[i][j]);
            }
            getchar();
        }
        memset(ans,0,sizeof(ans));
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(tu[i][j]=='*')
                {
                    ans[i-1][j-1]++;
                    ans[i-1][j]++;
                    ans[i-1][j+1]++;
                    ans[i][j-1]++;
                    ans[i][j+1]++;
                    ans[i+1][j-1]++;
                    ans[i+1][j]++;
                    ans[i+1][j+1]++;
                }
            }
        }
        memset(antu,0,sizeof(antu));
        int fl=0;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(flag[i][j]=='x')
                {
                    if(tu[i][j]=='*')    fl=1;
                    antu[i][j]=ans[i][j]+48;
                }
                else
                    antu[i][j]='.';
            }
        }
        if(fl)
        {
            for(int i=1; i<=n; i++)
            {
                for(int j=1; j<=n; j++)
                {
                    if(tu[i][j]=='*')
                    {
                        antu[i][j]='*';
                    }
                }
            }
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                printf("%c",antu[i][j]);
            }
            printf("\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值