pat 甲1064. Complete Binary Search Tree (完全二叉搜索树)

1064. Complete Binary Search Tree (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
 
 
tips:将所给元素排序,然后按照完全二叉树的中序遍历插入;
堆的思想:左儿子2*father 右儿子2*father+1;
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;

int a[1004];
int b[1004];
int n,rt;
int sz=1;
void dfs(int x)
{
	if(x>n)return;
	dfs(x<<1);
	b[x]=a[sz++];
	dfs(x<<1|1);
 } 
void bfs()
 {
 	queue<int>q;
 	q.push(1);
 	while(!q.empty())
 	{
		int tt=q.front();q.pop();
		if(tt==1)cout<<b[1];else cout<<" "<<b[tt];
		
		if((tt<<1)<=n) q.push(tt<<1);
		if((tt<<1|1)<=n)q.push(tt<<1|1);	
	 }
 }
int main()
{
	cin>>n;
	for(int i=1;i<=n;i++)cin>>a[i];
	
	sort(a+1,a+n+1);
	
	dfs(1);
	bfs();
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值