hdu 1532 Drainage Ditches(Edmonds-Karp最大流算法)

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16639    Accepted Submission(s): 7900


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50
 
tips;最大流问题,这里使用的是Edmonds-Karp算法;
思路:最大流满足三个性质:容量限制c(u,v)>=f(u,v);斜对称性f(u,v)=-f(v,u);流量平衡 除起点和汇点外各点流量流入等于流出,起点流出等于汇点流入
当且仅当残量网络中昂不存在增广路时,此时的流是从源点到汇点的最大流。

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<vector>
#include<queue>
using namespace std;
const int inf=0x3f3f3f3f; 

struct edge{
	int u,v,c,f;//起点,终点,容量,流量 
};
vector<edge>edges;

int a[1001];//增光路中流量的最小值,同时起到标记数组的作用 
int p[1001];//点的入边序号 
vector<int>g[1001];
int n,m,s,t,flow;//点的数量,边的数量,起点,汇点 ,最大流 
void init()
{
	for(int i=0;i<=n;i++)g[i].clear();
	edges.clear();
}
void insert(int u,int v,int c,int f)
{
	edges.push_back(edge{u,v,c,f});
	g[u].push_back(edges.size()-1);
}
int main()
{
	while(cin>>m>>n)//,n+m)
	{
		init();
		flow=0;
		s=1,t=n;
		for(int i=1;i<=m;i++)
		{
			int x,y,z;cin>>x>>y>>z;
			insert(x,y,z,0);
			insert(y,x,0,0);
		 } 
		 while(1)
		 {
		 	memset(a,0,sizeof(a));
		 	a[s]=inf;
		 	queue<int>q;
		 	q.push(s);
			 
			while(!q.empty())
			{
				int x=q.front();q.pop();
				
				for(int i=0;i<g[x].size();i++)
				{
					edge e=edges[g[x][i]];
					if(!a[e.v]&&e.c>e.f)
					{
						a[e.v]=min(e.c-e.f,a[x]);
						p[e.v]=g[x][i];
						q.push(e.v); 
					}
				}
				if(a[t])break;//如果找到一条增光路 
			 } 
			 
			if(!a[t])break;//如果找不到增光路 
			for(int u=t;u!=s;u=edges[p[u]].u)
			{
				edges[p[u]].f+=a[t];//更新流量信息
				edges[p[u]^1].f-=a[t];
			}
			flow+=a[t];
			 
		 }
		 cout<<flow<<endl;
		 
		 
		 
	}
	
	return 0;
}

 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值