PAT甲级 1112 Stucked Keyboard (20 分)

113 篇文章 9 订阅

1112 Stucked Keyboard (20 分)

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

参考链接:https://blog.csdn.net/qq_34594236/article/details/68200192

题目大意:键盘某些键卡住了,按一次重复k次,要求找出可能的键,并且输出正确的字符串顺序。可能的键要求按照被发现的顺序输出。

解题思路:用v来判断是好的还是坏的,vis用来判断是否已经输出过。

#include<iostream>
#include<cstdio>
using namespace std;

int main(){
	int n,cnt;
	cin>>n;
	getchar();
	string str;
	getline(cin,str);
	char ch = str[0];
	cnt = 1;
	str += "#";
	int v[256] = {0},vis[256] = {0};
	for(int i=1;i<str.size();i++){
		if(ch == str[i])
			cnt++;
		else{
			if(cnt % n)//一定要用求余才对,如n = 3,而cnt = 4表示是好的 
				v[ch] = 1;//1代表好的,0代表坏 
			cnt = 1;
			ch = str[i];
		}	
	}
	for(int i=0;i<str.size()-1;i++){
		if(v[str[i]]==0 && vis[str[i]]==0){
			printf("%c",str[i]);
			vis[str[i]] = 1;//记录已经打印出来的坏的,只打印一次 
		}
	}
	printf("\n");
	for(int i=0;i<str.size()-1;i++){	
		printf("%c",str[i]);
		if(v[str[i]] == 0){
			i += n-1;
		}	
	}
	
	return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值