Lightoj--1338--Hidden Secret!(模拟)


Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %lld & %llu

 Status

Description

In this problem you are given two names, you have to find whether one name is hidden into another. The restrictions are:

1.      You can change some uppercase letters to lower case and vice versa.

2.      You can add/remove spaces freely.

3.      You can permute the letters.

And if two names match exactly, then you can say that one name is hidden into another.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with two lines. Each line contains a name consists of upper/lower case English letters and spaces. You can assume that the length of any name is between 1 and 100 (inclusive).

Output

For each case, print the case number and "Yes" if one name is hidden into another. Otherwise print "No".

Sample Input

3

Tom Marvolo Riddle

I am Lord Voldemort

I am not Harry Potter

Hi Pretty Roar to man

Harry and Voldemort

Tom and Jerry and Harry

Sample Output

Case 1: Yes

Case 2: Yes

Case 3: No


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s1[1010],s2[1010];
int ch[1010];
int main()
{
	int t,k=1;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		memset(s1,0,sizeof(s1));
		memset(s2,0,sizeof(s2));
		memset(ch,0,sizeof(ch));
		gets(s1);
		gets(s2);
		for(int i=0;i<strlen(s1);i++)
		{
			if(s1[i]==' ') continue;
			int op;
			if(s1[i]>='a'&&s1[i]<='z')
			{
				op=s1[i]-'a';
				ch[op]++;
			}
			else if(s1[i]>='A'&&s1[i]<='Z')
			{
				op=s1[i]-'A';
				ch[op]++;
			}
		}
		bool f=false;
		for(int i=0;i<strlen(s2);i++)
		{
			if(s2[i]==' ') continue;
			int op;
			if(s2[i]>='a'&&s2[i]<='z')
			{
				op=s2[i]-'a';
				if(ch[op]!=0)
				ch[op]--;
				else f=true;
			}
			else if(s2[i]>='A'&&s2[i]<='Z')
			{
				op=s2[i]-'A';
				if(ch[op]!=0)
					ch[op]--;
				else 
					f=true;
			}
		}
		if(!f) printf("Case %d: Yes\n",k++);
		else printf("Case %d: No\n",k++);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值