【枚举】POJ 1013 Counterfeit Dollar

题目地址:

http://poj.org/problem?id=1013

题目描述:

Counterfeit Dollar

Time Limit: 1000MS
Memory Limit: 10000K

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A–L. Information on a weighing will be given by two strings of letters and then one of the words up'',down’’, or ``even’’. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input
1
ABCD EFGH even
ABCI EFJK up
ABIJ EFGH even

Sample Output
K is the counterfeit coin and it is light.

思路:

思路就是枚举每个硬币是轻和重的情况,然后直到找到符合条件的情况出现为止,具体见代码和注释。

题解:

import java.util.*;

public class Main {

    public static String[] left = new String[3];//天平左边硬币
    public static String[] right = new String[3];//天平右边硬币
    public static String[] result = new String[3];//称量结果

    public static boolean isFake(char c,boolean light){
    //c代表硬币,light为真表示硬币c为轻,否则为重
        for(int i=0;i<3;i++){
            String pleft,pright;//指向天平两端的字符串
            if(light);
            {
                pleft = left[i];
                pright = right[i];
            }
            if(!light)//如果假设硬币是重的,把称量结果对换,这样下面switch语句里的代码就统一,不需要区分硬币的轻重情况
            {
                pleft = right[i];
                pright = left[i];
            }
            switch (result[i].charAt(0)){
                case 'u':
                    if(pright.indexOf(c)==-1)//如果天平右边轻,但是假设的轻的硬币c不在右边,则说明c不是轻的假币
                        return false;
                    break;
                case 'e':
                    if(pleft.indexOf(c)!=-1||pright.indexOf(c)!=-1)
                        return false;
                    break;
                case 'd':
                    if(pleft.indexOf(c)==-1)
                        return false;
                    break;
            }
        }
        return true;
    }

    public static void main(String[] args){
        Scanner scanner = new Scanner(System.in);
        String line;
        line = scanner.nextLine();
        int n = Integer.valueOf(line.trim());
        while(n--!=0){
            line = scanner.nextLine();
            String space = " ";
            String[] temp = line.split(space);
            left[0] = temp[0];
            right[0] = temp[1];
            result[0] = temp[2];
            line = scanner.nextLine();
            temp = line.split(space);
            left[1] = temp[0];
            right[1] = temp[1];
            result[1] = temp[2];
            line = scanner.nextLine();
            temp = line.split(space);
            left[2] = temp[0];
            right[2] = temp[1];
            result[2] = temp[2];
            for(char j='A';j<='L';j++)
                if(isFake(j,true)) {
                    System.out.println(j+" is the counterfeit coin and it is light.");
                    break;
                }
                else if(isFake(j,false)) {
                    System.out.println(j+" is the counterfeit coin and it is heavy.");
                    break;
                }
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值