Mario and Mushrooms(组合数学)

原题链接
Mario and Mushrooms

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 689 Accepted Submission(s): 530

Problem Description
Mario usually relaxes himself by walking along the shady track near the Mushroom Kingdom. The evil King Koopa noticed that and placed a lot of mushroom on the road. There are two types of mushrooms, max mushrooms and bad mushrooms. The bad mushrooms will decrease Mario’s HP by m points, on the other hand, max mushrooms will increase Mario’s HP by one point. The mushrooms are randomly placed on the track and Mario will receive them one by one. Once Mario’s HP becomes zero or below after he received a mushroom, he will die.
Notice that Mario begins with HP zero, so if the first mushroom is bad, Mario will die immediately. Fortunately, if Mario receives all the mushrooms, he will be alive with HP 1. In the other words, if there are k bad mushrooms on the way, there will also be m*k+1 max mushrooms.
Princess Peach wants to know the possibility for Mario staying alive. Please help her to calculate it out.

Input
There are several test cases. The first line contains only one integer T, denoting the number of test cases.
For each test case, there is only one line including two integers: m and k, denoting the amount of points of HP the Mario will decrease if he receives a bad mushroom, and the number of bad mushrooms on the track. (1 <= m <= 1000, 1 <= k <= 1000)

Output
For each test case, output only real number denoting the possibility that Mario will survive if he receives all the randomly placed mushrooms one by one. The answer should be rounded to eight digits after the decimal point.

Sample Input
2
1 1
60 80

Sample Output
Case #1: 0.33333333
Case #2: 0.00020488

这个题当时刚做的时候和队友讨论了很多,队友说要用组合数学的知识去推导,我觉的可以用dp来做,于是我们分头来做这个题,但是很可惜,他的数学公式没有推出来,我写的dp也有着一个缺陷至今也没有调出来那就是采用滚动数组后结果就不正确了,这个我也没有好的办法。但其实最后那个公式特别简单,这就告诉我们一个道理,有的时候像组合数学的题就真的还是要敢大胆的找规律去

//http://acm.split.hdu.edu.cn/showproblem.php?pid=4015
//这个题本质上就是一个组合数学的题,只要你能找到那个规律就一定能做出来
#include <cstdio>
int main(){
	int T,kase=0;
	scanf("%d",&T);
	while(T--){
                int m,k;
                scanf("%d%d",&m,&k);
                printf("Case #%d: %.8f\n",++kase,(double)1/(k + k*m +1));
	}
	return 0;
}
这个题原本dp也是能做的,但是一来开不出那么大的空间,而二来复杂度太高
/*
#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;

const int INF=0x3f3f3f3f;
const int maxn=500 + 5;
double dp[2][maxn*maxn + 1];
int main(){
	int T,kase=0;
	scanf("%d",&T);
	while(T--){
                int m,k;
                scanf("%d%d",&m,&k);
                memset(dp,0,sizeof(dp));
                int hao=k*m+1;int sum=hao + k;
//这是豪大大写的滚动数组
//                for(int i=1,state=1;i<=K*M+M+1;++i,state^=1){
//                        for(int j=0;j<=K;++j){
//                                if() ans+=dp[state][j];
//                                else{
//                                        dp[state^1][j]=
//                                }
//                        }
//                }

                dp[0][0]=1;
                for(int i=0;i<=k;i++){
                        for(int j=0;j<=m*k+1;j++){
                                if(j>=1) dp[i][j]=(dp[i][j-1]*(hao-j+1)/(sum-i-j+1))+dp[i][j];
                                if(i*m<j && i>=1) dp[i][j]=(dp[i-1][j]*(k-i+1)/(sum-i-j+1))+dp[i][j];
                        }
                }
                printf("Case #%d: %.8f\n",++kase,dp[k][k*m+1]);
	}
	return 0;
}
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值